My touchpad is no longer working. Here is what I get when I do not have an external mouse plugged in:

$ sudo xinput list
[sudo] password for gwlester: 
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Asus Keyboard                             id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Asus Keyboard                             id=16   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=15   [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=14   [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam: USB2.0 HD           id=11   [slave  keyboard (3)]


  • Asus model? Should have something like FocalTechPS/2 FocalTech Touchpad. Try with a live distro and this/this Jul 1, 2022 at 17:07
  • The model is a GL753V Jul 2, 2022 at 22:54
  • As suggested, did: sudo modprobe -r psmouse # PS/2 mouse driver sudo modprobe psmouse proto=imps # Add proto=imps option No errors but no effect. Jul 2, 2022 at 22:57

1 Answer 1


Some diagnostics would be helpful.

  1. Does the touchpad work when running from a Live Ubuntu USB? If so, you know the cause is with the installed system; if not, the cause is hardware.
  2. What occurred before this issue? Ubuntu update? Power failure? Spilled coffee? Something else?
  3. Have you shut down and rebooted?
  4. In the Synaptic Package Manager, have you checked status of packages? Tried Edit | Fix Broken Packages?
  5. Have you tried fixing broken packages from Terminal?
  • 1) Downloading Live and will attempt to run and report results. 2) Stopped working after an upgrade. Finally got annoyed enough to fix. 3) Many, many, many times. 4) Yes, shows no broken packages. 5) Yes, shows nothing wrong. Jul 2, 2022 at 23:07
  • You state, "Stopped working after an upgrade." That important bit of data should have been in the question, which would have led to an obvious suggestion: back out the upgraded packages. Of course, by now, there will have been other upgrades, making it more difficult to identify the culprit(s). Jul 3, 2022 at 3:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.