I have a CD with Ubuntu 10.10 and a laptop with Ubuntu 8.10. The laptop had all sorts of crud on it, and anything I wanted to keep was backed up on an external drive, so I was happy to do a wipe and reinstall instead of an update. So after a bit of faffing about trying to work out how to get the thing to boot from the CD drive, I did that.

So the screen comes up with the choice: the options are Try Ubuntu and Install Ubuntu. I choose to install and to overwrite my current installation. So far so good. I then get a progress bar labelled something like copying files (I forget the exact wording) and further options to fill in for my location, keyboard locale, username and password. On each of these screens there are forward and back buttons. On the last screen (password), the forward button is greyed out. Well, I think to myself, no doubt it will become active when that copying files progress bar completes.

The progress bar never completes. It hangs. And the label changes from copying files to the chirpy ready when you are. The forward button remains greyed out. The back button is as unhelpful as you'd expect it to be. And there's nothing else to click. We have reached an impasse.

I tried restarting the laptop, to test whether it actually was properly installed. It wasn't. I tried to run Ubuntu live from the CD, to test whether the disk was damaged. That wouldn't work either, but I suspect it's just because the laptop is old and has a slow disk drive. I'm typing this question on another computer using the Ubuntu live CD and it's working fine. So there's nothing wrong with the CD.


6 Answers 6


I recently encountered the same problem installing Ubuntu on a friend’s computer. It seems that Ubiquity (the Ubuntu installer) for 10.10 is not very informative when things go wrong. Does your username contain uppercase letters? Try making sure all letters in your username are lower case.

For more details, see: How should I file a bug about Ubiquity?

Corresponding Bug Reports:

  • And it's now properly installed. Thanks. Odd that it gives a sensible error message for some types of error (the space) but not for others (capital letters). Oddly, Ubuntu 8 did give me a sensible error when I tried capital letters there while installing it, and Ubuntu 9 (on my desktop) allowed capital letters.
    – TRiG
    Nov 21, 2010 at 18:05

Each line in the installer should have a green check-mark next to it. For example, if you've not entered a password or mistyped the password, the "Forward" button will remain greyed out.

alt text

  • All green checkmarks. Passwords matched. And the password message wasn't "Weak password". I forget what exactly the message was, but it implied the password was reasonable.
    – TRiG
    Nov 21, 2010 at 15:12
  • Does it work with really simple inputs? E.g. Name: Example, computer: machine, username: example ? If not, you've found a bug. :( Try reporting the issue here: bugs.launchpad.net/ubuntu/+source/ubiquity/+filebug
    – Kees Cook
    Nov 22, 2010 at 23:30

We used to get this question a lot, at https://answers.launchpad.net/ubuntu.

Depending on what version of Ubuntu you are installing, this may be happening because you've entered an invalid username.

  • On Ubuntu releases prior to 11.04, the installer doesn't show any message to inform users that they've chosen invalid usernames. This produced considerable confusion, since many users didn't know why they couldn't continue on with the installation. That seems to be what's going on here.

    This was reported as bug 549195 and fixed for Ubuntu 11.04 and later.

If you choose a username consisting only of lower-case letters (and, if you want, also numbers, but not as the first character), and no punctuation or spaces, that should enable you to proceed forward with the installation.

  • Some punctuation-like characters are allowed, but not most. Here are the details, from a post on Launchpad Answers by Colin Watson (#4 here):

    Make sure that your username begins with a lower-case letter, and contains only lower-case letters, digits, hyphens (-) or underscores (_). Upper-case letters and spaces, in particular, are not allowed. (Of course, the full name can be whatever you like.)

If you still cannot click Continue, then you should MD5 test the installation .iso image you used to make the live CD/DVD or USB flash drive. If that doesn't check out, you'll have to download a new .iso file and start over. If that does check out, then check the installation media (CD/DVD or USB flash drive) for defects.

If your username starts with a letter and doesn't contain any disallowed characters, and the .iso image and the installation media you created from it are good, and this problem still occurs (which is unlikely), then you should still be able to install with the text-based alternate CD.


Username can ONLY have lowercase letters and numbers, and should begin with a letter.


If you don't mind an installer that looks a bit dated, is a tiny bit harder to use, you could try the Alternate Installation disk.

Downloads: alt text 32 bit iso / alt text 64 bit iso

enter image description here

This method of installation uses far less resources, which always helps when something's wrong. Also, if this installation hangs as well, you can press Alt+ and Alt+ to see some system log messages*, which might point you and us to what's wrong. (You should be able to do the same on the normal Live installation, using Ctrl+Alt+F1..F7, but I'm not sure whether it's the same business).

* press those any time, even while things are running, you can always go back.


You can chose "Try Ubuntu" option, then go to Application > Accessories > Terminal and type ubiquity --no-migration-assistant

  • The "Try Ubuntu" option also hanged.
    – TRiG
    Nov 21, 2010 at 15:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.