Two days ago I installed Ubuntu 22.04 and I was trying to restart GNOME Shell using Alt+Fn+F2. The command prompt opened, but when I entered r and pressed Enter, GNOME Shell does not restart.

The following message was coming as displayed on the image:

Restart is not available on Wayalnd

screenshot showing the error message

What can I do now to resolve this problem?


2 Answers 2


Please enter this command:


If the above command outputs, wayland, your system is using Wayland, and as the error in the screenshot informs, restart is not available on a Wayland session. We have to disable Wayland and enable Xorg (X11) to be able to restart GNOME Shell.

To do this follow these steps:

  1. Open the /etc/gdm3/custom.conf file with nano:

    sudo nano /etc/gdm3/custom.conf
  2. Uncomment this line.

  3. Reboot your system.

Voila! You can now press Alt+F2, enter r and press Enter to restart GNOME Shell.

Also, running:


should now display x11.



a Gnome mailing list thread says that:

runDialog: Disable restart command on wayland

Clients can be expected to deal with the WM going away temporarily, but not the display server - so when running as wayland compositor, a restart is generally a fancy way of killing the user session, and there's little we can do about it except for preventing the user to shoot herself in the foot by throwing an error.

  • That means I cannot do anything to solve this? Commented Jun 30, 2022 at 9:13
  • Under Wayland, gnome-shell does not have a graceful way to restart and leave the applications open. If you must restart gnome-shell then you are probably better off saving all of your work and using the menu to log out. If that's not working for some reason, the command killall -HUP gnome-shell will get it done from the command runner (Alt+F2) or terminal.
    – Daniel
    Commented Jun 30, 2022 at 9:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .