22

from 30 minutes ago on slack refuses to start on my 20.04 box. Last thing i did before it stopped working was updating firefox to 102.0 but i'm not confident if this is related to it.

I downloaded the recent slack 4.27.154 deb package from their website and installed it through through apt install, however it still refuses to start.

Here's the console output:

> slack 
Initializing local storage instance
[winston] Attempt to write logs with no transports {"error":{},"level":"error","message":"Unable to create logs directory"}
[winston] Attempt to write logs with no transports {"level":"info","message":"\n╔════════════════════════════════════════════════════════════╗\n║      Slack 4.27.154, linux 5.15.0-10033-tuxedo on x64      ║\n╚════════════════════════════════════════════════════════════╝"}
[winston] Attempt to write logs with no transports {"meta":{"shouldUseNewBackend":false,"loggerInstanceCount":1},"level":"info","message":"Configured logger via"}
[winston] Attempt to write logs with no transports {"meta":{"NODE_ENV":"production","platform":"linux","type":"browser","timeZone":"Europe/Berlin","PACKAGE_MANIFEST.productName":"Slack","PACKAGE_MANIFEST.version":"4.27.154","PACKAGE_MANIFEST.commit":"8956995","PACKAGE_MANIFEST.branch":"HEAD"},"level":"info","message":"Predefined values for process"}
[winston] Attempt to write logs with no transports {"level":"debug","message":"getLogger: Winston backend does not support child logger"}

I also noticed a strange error when trying to get the help information:

❯ slack --help
A JavaScript error occurred in the main process
Uncaught Exception:
TypeError: b is not a function
    at y (/usr/lib/slack/resources/app.asar/dist/boot.bundle.js:1:32588)
    at Pt (/usr/lib/slack/resources/app.asar/dist/boot.bundle.js:1:7238)
    at Object.<anonymous> (/usr/lib/slack/resources/app.asar/dist/boot.bundle.js:1:5038)
    at Object.D (/usr/lib/slack/resources/app.asar/dist/boot.bundle.js:1:4765)
    at /usr/lib/slack/resources/app.asar/dist/boot.bundle.js:32:16305
    at /usr/lib/slack/resources/app.asar/dist/boot.bundle.js:32:16414
    at /usr/lib/slack/resources/app.asar/dist/boot.bundle.js:32:16418
    at Object.<anonymous> (/usr/lib/slack/resources/app.asar/dist/boot.bundle.js:32:16440)
    at Module._compile (node:internal/modules/cjs/loader:1118:14)
    at Module._extensions..js (node:internal/modules/cjs/loader:1173:10)

Anyone has any idea what the problem is? I'm not finding anything on this stuff in the web.

4
  • Just in case this helps, try restarting the computer. Jun 29 at 8:26
  • @ArchismanPanigrahi, tried it. didn't.
    – plazmakeks
    Jun 29 at 8:28
  • Seeing the same issue here on both 20.04 and 18.04 Jun 29 at 10:15
  • 1
    Also seeing this on 22.04. Jun 29 at 15:50

5 Answers 5

12

**UPDATE : July, 8th **

Available working version now from slack is : 4.27.156

https://downloads.slack-edge.com/releases/linux/4.27.156/prod/x64/slack-desktop-4.27.156-amd64.deb


OUTDATED proposal : I confirm also that this version of Slack seems to have problems.

as explained by @Iam Strad you can install Slack from snapcraft, unfortunately, it will probably not be enough as it brings you the same version 4.27.154 2022-06-27.

But with snap you can find an older version of slack that is still functional until a better version is published.

sudo apt update
sudo apt install snapd
sudo snap install slack --channel=insider/edge

or

sudo snap refresh slack --channel=insider/edge

it should bring you version 4.25.1 that could be a temporary workaround .

> snap info slack

name:      slack
summary:   Team communication for the 21st century.
publisher: Slack✓
store-url: https://snapcraft.io/slack
(...)
channels:
  latest/stable:     4.27.154 2022-06-27 (63) 110MB -
  latest/candidate:  ↑                              
  latest/beta:       ↑                              
  latest/edge:       ↑                              
  insider/stable:    –                              
  insider/candidate: –                              
  insider/beta:      –                              
  insider/edge:      4.25.1   2022-04-01 (61) 108MB -
installed:           4.25.1              (61) 108MB -
4
  • 2
    Directly from slack support, they propose those two alternatives which are closed from what was proposed on this page : If you're on the Snap Store version you should be able to do this via sudo snap revert slack If you are on the .deb, you can download 4.26.1 here: downloads.slack-edge.com/releases/linux/4.26.1/prod/x64/…
    – torr-penn
    Jun 29 at 15:58
  • 1
    it fixed the problem after running top and killing Slack processes. Jul 1 at 9:02
  • Just received the upgrade to 4.27.156 but it seems to be still broken. :-(
    – jelhan
    Jul 6 at 12:55
  • 1
    4.27.156 is working after I killed all stale slack processes. :tada:
    – jelhan
    Jul 6 at 14:53
11

Downgrading seems to work, as a workaround for now;

sudo apt install slack-desktop=4.26.1
3
  • This worked for me. Thank you. Ubuntu 20.04.
    – zergussino
    Jun 29 at 11:13
  • $ sudo apt install slack-desktop=4.26.1 Reading package lists... Done Building dependency tree Reading state information... Done E: Version '4.26.1' for 'slack-desktop' was not found also tried slack=4.25.1 Jun 30 at 10:17
  • 2
    Thx but didn't WFM (Ubuntu 20.04). After downgrade, running slack from command line no longer outputs [winston] Attempt to write logs with no transports errors after Initializing local storage instance, but slack still doesn't start. Worrying. Don't want to reboot at the mo. so I'll use slack from my browser until I next reboot. Jul 1 at 9:39
3

As a workaround you could use slack with chromium. In a terminal you could execute: chromium --app=https://yourslackworkspace.slack.com

If that works, create your own desktop file in /home/user/.local/shares/applications for easy access:

[Desktop Entry]
Version=1.0
Type=Application
Name=Chromium Slack chat
Comment= Slack chat app
Exec=chromium --app=https://yourslackworkspace.slack.com
Icon=/home/user/.local/share/applications/slack.png
Path=
Terminal=false
StartupNotify=true
StartupWMClass=yourslackworkspace.slack.com

I'm running slack with this config, calls, huddle etc works out of the box

0

For those who have the it installed on apt-get:

In my search for an older version to roll back to, I ended up scouring the flathub code for a url for downloading an older .deb and came across:

https://downloads.slack-edge.com/releases/linux/$version/prod/x64/slack-desktop-$version-amd64.deb

Replacing the $version with a version number found on the slack release notes page did the trick.

Example:

wget https://downloads.slack-edge.com/releases/linux/4.26.1/prod/x64/slack-desktop-4.26.1-amd64.deb

and then

sudo dpkg -i slack-desktop-4.26.1-amd64.deb

UPDATE: I could have probably saved a lot of trouble by following the dowgrade path for flatpak apps.

0

I found these problems, my slack was installed by *.deb and yesterday I updated to version 4.27. I solved it by updating the nvidia video card drivers, using the drivers from the nvidia-driver package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.