This is an attempt to create a canonical question that covers all instances of "low-graphics mode" error that occurs to a user, including but not limited to installation of wrong drivers, incorrect or invalid lightdm greeters, low disk space, incorrect installation of graphics card like ATI and Nvidia, incorrect configuration of xorg.conf file while setting up multiple monitors among others.

If you are experiencing the "low-graphics mode" error when trying to login but none of the following answers work for you, please do ask a new question and then update the answers of this canonical question as and when your new question gets answered.

When I try to boot into my computer, I am getting this error:

The system is running in low-graphics mode

Your screen, graphics cards, and input device settings could not be detected correctly. You will need to configure these yourself.

fail-safe X mode

How do I fix the failsafe X mode and login into my computer?

Answer index:

  • What happens when the message you see here is almost impossible to read? And I can forget about being able to see the terminal in the Ctrl-Alt-F1 trick. Jun 6, 2013 at 16:23
  • I tried to add to the master question but apparently am too much of a newb to be useful.
    – peejaybee
    Sep 29, 2013 at 0:26
  • ok i tried everything on this page, but the fix for me was to make some more room. "df -h" showed sda1 as 100% so then i run "du / | sort -g" and found trash was like 30gig... 80% of harddrive, so i did "rm -fr ~/user/.blah/trash" and followed up with another df -h showing 14%, so a final reboot and i was back in.
    – scott
    Jan 18, 2014 at 6:24
  • @Braiam I realize this is old, but... this question is protected. It's pretty obviously visible.
    – alexia
    Mar 15, 2015 at 0:17
  • I had the same problem but i fixed it from this link thegeekyland.blogspot.com/2014/07/ubuntu-1404-lenovo-g510.html
    – Arlind
    Aug 2, 2015 at 8:01

46 Answers 46


I'm running Ubuntu 12.04 on a Toshiba Portege R100. I got this error after the first bootup after install. After downloading and updating the graphics driver (Trident Cyberblade), what worked for me was creating a driver-specific .conf file as described in this Arch-Linux wiki: https://wiki.archlinux.org/index.php/Trident.

  • Wanted to add that, clearly, this is an Arch Linux link, not an Ubuntu link, but the solution worked for me. Now, however, I'm digging into it further, in terms of turning different options on and off, and I realize it works very differently from the way described in the comments. So keep this in mind if you try this.
    – David
    Apr 29, 2013 at 1:47

I fixed this problem by creating a new xorg.conf file (copying the text from xorg.conf.failsafe).

Details: https://askubuntu.com/a/296217/55223


I had the “The system is running in low-graphics mode” error after trying to upgrade my Acer Aspire 4810T with Intel GM45 Express Chipset graphics from a 64bit 13.04 to a 64bit 13.10.

I had less than 2 gigabytes of free disk space when I started the upgrade. I faced first anomalies already before the reboot. The upgrade window showing the progress showed that everything has been downloaded and installed but it never closed. Couldn't close it even manually.

Then, after reboot, I got the “The system is running in low-graphics mode” error window.

I tried to solve the problem as proposed above by Luis Alvarado, user41938, community wiki, Azul Mascara and David M. Sousa.

My guess is that my problem was related to tiny disk space as hinted by Azul Mascara. But just freeing disk space and even allocating more by repartitioning didn't help.

After struggling more than enough with the problem I decided to download the 13.10 64bit and make a bootable USB stick with it. I booted the laptop with the USB stick and selected the installation on top of the old 13.10 (non-functioning) system that the installer recognized. This fixed my problem.


First, type the following commands:

$ lspci | grep -i VGA
$ lspci | grep -i amd

For me (HP pavilion 15n003tx, Saucy), the outputs were:

test@HP-Pavilion-15:/etc/X11$ lspci | grep -i VGA
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
test@HP-Pavilion-15:/etc/X11$ lspci | grep -i amd
0a:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M]

Since the AMD device doesn't come as output in the first command, even if you install amd drivers, you'll probably end up with the following error in /var/log/Xorg.0.log:

[    12.873] (II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not VGA-enabled

Hence, I followed the steps:

test@HP-Pavilion-15:/etc/X11$ sudo apt-get purge fglrx*
test@HP-Pavilion-15:/etc/X11$ cp /etc/Xorg/xorg.conf.failsafe /etc/xorg.conf

The contents of xorg.conf.failsafe are:

Section "Device"
    Identifier  "Configured Video Device"
    Driver      "fbdev"

Section "Monitor"
    Identifier  "Configured Monitor"

Section "Screen"
    Identifier  "Default Screen"
    Monitor     "Configured Monitor"
    Device      "Configured Video Device"

I fixed this problem by removing /var/lib/lightdm/.Xauthority manually.

You can also try deleting the file ~/.Xauthority and rebooting.


I have the same problem (The system is running in low-graphics mode) when I reboot the system connected to an Oculus Rift (1080x1920 monitor). If I reboot the machine and connect a monitor of (1920x1080 resolution) it works ok.

The machine has Ubuntu 14.04 and Nvidia 970, driver 346 and kernel 3.15. With the default lightdm configuration (autologin activated).

The problem started suddenly, without making major changes in Ubuntu configuration.

I had the same issue in another machine with nvidia 970, same version of Ubuntu / different kernel. On this machine the problem happened when changing from autologin to login with user/pw in lightm and it was solved rebooting the machine with a 1920x1080 monitor connected and enabling autologin again.


For me this problem occurred after upgrading from "Ubuntu 12.04 LTS" plus TDE to "Ubuntu 14.04 LTS" plus TDE. TDE is the trinity desktop environment (trinitydesktop.org). The cause of the error was that

  1. /etc/X11/default-display-manager pointed to lightdm although during the upgrade I told it to use tdm-trinity as default.
  2. lightdm was broken (and I don't care why).

The fix was to run dpkg-reconfigure tdm-trinity and to choose tdm-trinity as my default. A few days later the problem came back and again /etc/X11/default-display-manager pointed to lightdm, don't know why.


This one worked for me using ubuntu 13.10, my ubuntu stopped working after installing opencv.

sudo apt-get purge nvidia-304 nvidia-current nvidia-libopencl1-304 nvidia-settings 

Just purge all the nvidia-* and restart

I am not a geek just a layman don't know the reason why it works.


Different users solved their in different ways (since the causes of the problem were different for different people). I am describing what caused the problem in my desktop and how did I solve it.

WARNING: My method will work on your computer only if the cause of the problem is the same. Nevertheless read my reply to develop a general understanding.

Cause of the problem:

I made some changes to the file


After I rebooted I encountered the 'system-is-running-in-low-graphics-mode' error. Clearly the changes made to the above 'lightdm.conf' file needed to be undone.

How did I solve it:

  1. When the error message appears, press Ctrl+Alt+F1, then login using your ubuntu username and password.

  2. Go to the directory /etc/lightdm/ (cd /etc/lightdm/). Open the above file in vim using vim lightdm.conf. Vim opens the file in the terminal itself.

  3. Undo the changes that caused the problem. In my case I removed a line that I had added (which caused the problem). Save and quit vim. Following this step requires you to know how to use vim editor to edit files. If you are unfamiliar with vim watch tutorials on how to open a file, edit a file, save and quit a file in vim.

  4. Reboot the computer. The problem is gone!

PS: I undid the change that caused the error. Your cause of error could be completely different from mine. So, blindly following my answer definitely won't help. On the other hand it may damage your computer.


I got this error after upgrading from 14.04 to 15.10 (and then to 16.04). For some reason the /var/lib/lightdm directory was missing.

To fix the issue, first, create the directory:

sudo mkdir -p /var/lib/lightdm
sudo chown -R lightdm:lightdm /var/lib/lightdm
sudo chmod 0750 /var/lib/lightdm

Then create the .Xauthority file:

sudo touch /var/lib/lightdm/.Xauthority
sudo chown lightdm:lightdm /var/lib/lightdm/.Xauthority

More details:

Most of the solutions revolve around ATI or NVidia drivers, but I just have an Intel integrated graphics chip, so that wasn't the issue.

I discovered the actual problem by looking at the greeter log:

$ sudo cat /var/log/lightdm/x-0-greeter.log
Error writing X authority: Failed to open X authority /var/lib/lightdm/.Xauthority: No such file or directory

Indeed, the /var/lib/lightdm was absent. Just creating the empty directory (as recommended in another question's answer) resulted in the same error, but after creating the .Xauthority file, the system booted fine

Edit: Just found this question that has two answers: one recommending creating the directory, the other recommending creating the file. As I said, I needed to do both.


I face this error almost 100 times.

  **1.Go to tty mode (ctrl + alt + F1)**

   2. Login with the existing user credentials.
   3. Run the single command **(  sudo apt-get dselect-upgrade )**
   4. Reboot

I started seeing this error after upgrading to Ubuntu 17.10.

From a text console, I changed GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub to "nosplash nomodeset" so I could see the boot messages and ran sudo update-grub.

Upon reboot I saw that it was the "GNOME display manager" that had failed. Hey, wasn't I using LightDM? After running sudo dpkg-reconfigure lightdm to switch back from GDM3 to LightDM, it worked fine.


I had the same problem on a 16.04 box with Intel integrated graphics this morning and found my way here. What worked for me:

When presented with the low-graphics-mode message at boot and unable to click "OK", I pressed Ctrl + Alt + F1 to bring up the terminal (in glorious full-screen text mode), and logged in.

I was going to follow the steps to reinstall the whole desktop, but then I noticed there were updates available. sudo apt update revealed that kernel updates were among them, and sudo apt upgrade installed the updates. Then sudo shutdown -r now to reboot.

And the problem went away. Probably some kind of bug with a previous version of the kernel. The recent change that I made that may have brought this on was installing a larger VGA monitor with a native resolution of 1680 x 1050. Anyway, everything seems to be fine now.


The only solution that worked for me is to switch lightdm to gdm:

sudo apt-get install gdm3
sudo dpkg-reconfigure gdm3

systemctl stop lightdm
systemctl start gdm3

Reconfigure your display manager


sudo dpkg-reconfigure sddm

replacing sddm with you display manager (https://wiki.debian.org/DisplayManager), and choose one from the list that will be shown.


Yet another cause -- memory upgrade!

I have system with both Ubuntu 14.04 and Windows 10 installed. Both 64-bit, of course. It had been working just fine (well fine-ish) with only 8 GB of RAM installed. I decided to upgrade it to 32 GB (the max supported by the motherboard). After installing the new RAM, of course I booted memtest86 and tested the new memory very thoroughly: no errors after more than 24 hours of running the test. I booted Windows and it showed 32 GB of memory and had no issues. I booted into Ubuntu and got the "system is running in low graphics mode".

Nothing had changed except for the additional memory!

Any number of articles on the web -- here at askubuntu and elsewhere -- claim that if you have 64-bit kernels, no settings changes should be necessary when you upgrade memory; it should just work.

It was not a problem of having too-small a swap partition for the larger memory. That was one of the first things I checked. When the OS was installed a 90 GB swap partition had been created, which is more than enough.

After wasting about a day checking various things, what finally worked for me was to:

  • reboot into recovery mode
  • rerun the "mkswap" utility to re-initialize the swap partition.
  • reboot

See https://help.ubuntu.com/community/SwapFaq for details on how much swap space is needed and how to use the mkswap utility.

I can only guess that when it saw the expanded memory, the kernel decided that the page size of the swap file should have a new value, and that did not match whatever whatever the page size was when the swp partition was initialized. So then virtual memory failed to enable, and somehow that led to a cascade of failures.


Not the answer you're looking for? Browse other questions tagged or ask your own question.