0

Ubuntu 22.04 is recognising the Realtek RTL8188FTV 802.11bUSB Wifi adaptor, but no available networks show

enter image description here enter image description here enter image description here

lsusb

lsusb
Bus 002 Device 007: ID 0bda:f179 Realtek Semiconductor Corp. RTL8188FTV 802.11b/g/n 1T1R 2.4G WLAN Adapter

nmcli dev status

nmcli dev status
DEVICE           TYPE      STATE         CONNECTION         
enp3s0           ethernet  connected     Wired connection 2                 
enp2s0           ethernet  unavailable   --                 
wlx00e04c818802  wifi      unavailable   --              
lo               loopback  unmanaged     --

lshw -C network

lshw -C network
*-network DISABLED
       description: Wireless interface
       physical id: a
       bus info: usb@2:1.3
       logical name: wlx00e04c818802
       serial: 00:e0:4c:81:88:02
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=r8188eu driverversion=5.15.0-39-generic multicast=yes wireless=unassociated

sudo iwlist sca

sudo iwlist sca
lo        Interface doesn't support scanning.
enp2s0    Interface doesn't support scanning.
enp3s0    Interface doesn't support scanning.
wlx00e04c818802  No scan results

There are no Driver show in Additional Drivers Tab, how to resolve this issue

2

1 Answer 1

1

I got the exact same issue in my Ubuntu 22.04.1 LTS. It was recognizing RTL8188FTV 802.11bUSB Wifi adaptor but not scanning any network.

So, What I did (after spending a whole day on it):

  1. Install and configure the rtl8188fu driver by following this repo (I executed only following commands)
sudo apt-get install build-essential git dkms linux-headers-$(uname -r)
git clone https://github.com/kelebek333/rtl8188fu
sudo dkms add ./rtl8188fu
sudo dkms build rtl8188fu/1.0
sudo dkms install rtl8188fu/1.0
sudo cp ./rtl8188fu/firmware/rtl8188fufw.bin /lib/firmware/rtlwifi/

sudo mkdir -p /etc/modprobe.d/
sudo touch /etc/modprobe.d/rtl8188fu.conf
echo "options rtl8188fu rtw_power_mgnt=0 rtw_enusbss=0" | sudo tee /etc/modprobe.d/rtl8188fu.conf

  1. Black List r8188eu driver in /etc/modprobe.d/blacklist.conf

Edit this /etc/modprobe.d/blacklist.conf file to add blacklist r8188eu at the end of file.

  1. Finally reload the newly installed driver using following command sudo modprobe -rv rtl8188fu && sudo modprobe -v rtl8188fu
  2. Now reboot the system.

Summary:

  1. Install and configure a new driver rtl8188fu
  2. then backlisted the already existed driver r8188eu
  3. then reload the newly installed driver
  4. reboot system.

That's all.

Let me know if you need more help. I'd be happy to help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.