0

After I upgraded from 20.04 to 22.04, my modem seems to be missing. At least network/modem manager is not able to recognize it anymore. It is weird and I don't know what to do.

I tried two commands and got:

mmcli -L >> No modems were found

lsusb >> Bus 001 Device 002: ID 03f0:a31d HP, Inc HP lt4132 LTE/HSPA+ 4G Module

I suppose it could mean that there is some sort of problem with identifying the correct connection mode for the modem to work. But again, I have no idea what might cause the problem.

But because of my un-educated guess, I tried following the steps in How to use HP lt4132 mobile device on Linux, but with no success: Deconfiguring and enabling MBIM mode instead of ECM mode gave me an error.

I tried two commands and got:

grep lt4132 /sys/bus/usb/devices/*/product >> /sys/bus/usb/devices/1-3/product:HP lt4132 LTE/HSPA+ 4G Module

echo 0 > sys/bus/usb/devices/1-3/device/bConfigurationValue >> bash: sys/bus/usb/devices/1-3/device/bConfigurationValue: No such file or directory

So, here I am, asking for your guidance. Maybe using other versions of modem/network manager might help?

Thanks for helping out! :-)

1
  • I could not solve the problem and therefore decided to roll back to Ubuntu 20.04 instead. Jul 1 at 11:39

2 Answers 2

1

it seems to be an issue with USB Modeswitch missing the configuration for lt4132 see my post in the USB Modeswitch forum: https://draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=4&t=2710&p=19981#p19981

if you are good with different versions, in an older version of usb_modeswitch the configuration might work, maybe you could share the configuration here and try. I am not aware how to download an old version at the moment.

1

Hi i have solved my issue, maybe it helps someone else:

book:~# cat /etc/udev/rules.d/hp-lt4132.rules
ACTION=="add|change", SUBSYSTEM=="usb", ATTR{idVendor}=="03f0", ATTR{idProduct}=="a31d", ATTR{bConfigurationValue}!="3", ATTR{bConfigurationValue}:="0"
ACTION=="add|change", SUBSYSTEM=="usb", ATTR{idVendor}=="03f0", ATTR{idProduct}=="a31d", ATTR{bConfigurationValue}!="3", RUN+="/bin/sh -c 'sleep 1; echo 3 > %S%p/bConfigurationValue'"
ACTION=="add|change", SUBSYSTEM=="net", ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="a31d", ATTR{cdc_ncm/ndp_to_end}=="N", ATTR{cdc_ncm/ndp_to_end}:="Y"
book:~# 

afterwards reboot and see your Broadband appearing :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.