51

Whenever I try to install anything with the Ubuntu Software Center, the following error appears.

Failed to download repository information

Check your Internet connection.

E:Unable to parse package file /var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_precise_multiverse_i18n_Index (1)

  • The above does not work for me. I notice when running "apt-get update" the concatenated string contains the IP for this device (in my case 10.1.1.4), NOT the nameserver (10.1.1.1). It is then unable to connect. – user94170 Oct 2 '12 at 23:16
  • 1
    I'd like to add this as an answer to this protected question, but don't have the rep here yet. Anyway, I ran into this problem. In my case I had forgotten I had added a file to /etc/apt/sources.list.d/ for a 3rd party package from https://z.litestack.com/v1/repo/ubuntu/. That URL ceased to resolve (superseded by instructions at zerovm.org/download.htm), so apt-get would always end up tripping over that. sudo rm /etc/apt/sources.list.d/zerovm-precise.list fixed it for me. – Digital Trauma Apr 7 '14 at 16:27
  • I had this problem with 17.04, upgrading to 17.10 solved the problem – jim smith Apr 13 '18 at 11:07
55

Try cleaning up your apt-cache and running any updates

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade

If you still have issues, then change your repo mirror: Open Update Manager or Software Updater, then click Settings > Ubuntu Software tab, then select Other from the Download From menu and click the Select Best Server button. Now try updating/upgrading again.

  • You rock! This fixed my VMware Ubuntu! I was kind of freaking out that I'll have to re-install it but this worked great. – Georgi Angelov Mar 3 '16 at 5:13
  • 2
    Don't get too excited Georgi, your Linux machine will break again I promise lol – Alexander Mills Jul 19 '18 at 17:48
  • 1
    I tried this on Ubuntu netbook edition (10.10). When I tell it to Select Best Server, it goes through all 361 of them and then concludes, "No suitable download server was found. Please check your Internet connection." Yet, I can access the internet just fine. – Brad Turek Oct 18 '18 at 20:57
27

"Software Updater" will give same error message for issues like:

W: Failed to fetch http://ppa.launchpad.net/crass/ufraw/ubuntu/dists/raring/main/binary-amd64/Packages  404  Not Found

Solution: Settings -> Software & Updates -> Other Software -> Click on offending entry and hit Remove (OR simply un-check so its ignored yet visible for later)

  • 1
    Note this can also apply if "cdrom" is in the repo list, see askubuntu.com/a/386048/254 – matt wilkie Jan 28 '16 at 20:17
  • 3
    This is the correct answer; the problem is that the error message does not indicate which entry is the offending one. :( But yes, once you can figure that out, works like a charm! – Bane Mar 9 '16 at 16:02
  • Worked for me, too. I ran into this problem when I installed the blueman and bluez5 packages to support my Microsoft BT mouse. Clearing the checkboxes next to these packages on the "Other Software" tab in Software & Update fixed it. – Nicole Hamilton Jul 17 '16 at 1:16
  • That was it, "cdrom" was the offender (I'm running a virtual machine), unchecked it and the problem went away – rboy Sep 15 '17 at 3:45
3

Assure cdrom is unchecked then cut and paste entire set of below commands

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old_`date '+%Y%m%d_%H%M%S'`  
sudo mkdir -p lists/partial
sudo apt-get clean 
sudo apt-get update
-1

there is something that worked for me:

please goto update manager settings > under Ubuntu software tab uncheck "cdrom with Ubuntu 12.04 'precise pangolin'"

then under other softwares tab uncheck first three options which are cdrom with Ubuntu 11.04 and 12.04 and etc.

Not the answer you're looking for? Browse other questions tagged or ask your own question.