0

I recently upgraded from Kubuntu 18.04 LTS to 20.04 LTS and as usual with Ubuntu upgrades, stuff broke.

After the upgrade DVDs didn't work at all, but after apt installing libdvd-pkg and running dpkg-reconfigure on it at least something was fixed. DVDs are now mounted to /media/username/DVDname and I can see files on the DVD.

However, some stuff still doesn't work and I haven't found much online that seems relevant, and what I've tried hasn't worked.

When inserting a DVD, it doesn't appear in KDE's removable device notifications. It just remains empty, "no devices attached".

The DVD may appear in Dolphin, or it may not, and if it does appear it may take a long time. Navigating a DVD in Dolphin is extremely slow, as is opening any files, and copying files in the terminal is also slow and often results in a read error.

Trying to open a DVD in Dolphin works occasionally, but ocasionally there's an error: Error mounting /dev/sr0 at /media/...: no medium found on /dev/sr0

Trying to eject a DVD in Dolphin when that error happens causes another error: Error ejecting /dev/sr0: Command line `eject '/dev/sr0" exited with non-zero exit status 1: eject: <localized error message with something about device incompatible ioctl>

In case the DVD gets into a state where it can be opened in Dolphin, trying to eject it in Dolphin causes Dolphin to crash. The resulting error notification wizard asks to install some debug packages, which also ends in an error, but that's probably unrelated to the DVD issue.

Trying to play a DVD in VLC causes it to load for a long time and then ends with an error.

Did the 20.04 LTS upgrade remove something else which I'm still missing or what? I've got libdvd-pkg 1.4.2-1-1, libdvdcss2 1.4.2-1~local, libdvdcss-dev 1.4.2-1~local, libdvdread7 6.1.0+really6.0.2-1, libdvdread4 6.0.0-1, dvd+rw-tools 7.1-14build1, libdvdnav4 6.0.1-1build1 and lsdvd 0.17-1build2 at least, looking at installed DVD-related packages. Also libavcodec-extra58 7:4.2.7-0ubuntu0.1.


EDIT: Not working at all today. Went over this because of the error message: DVD : no medium found on /dev/sr0 when there is a DVD

eject /dev/sr0 => localized error message about device incompatible ioctl
sudo mount /dev/sr0 /media/grimripper/DVD/ => mount: /media/grimripper/DVD: no medium found on /dev/sr0.

lshw (only the part about the DVD drive):
     *-scsi
          physical id: b
          logical name: scsi1
          capabilities: emulated
        *-cdrom
             description: SCSI CD-ROM
             physical id: 0.0.0
             bus info: scsi@1:0.0.0
             logical name: /dev/cdrom
             logical name: /dev/cdrw
             logical name: /dev/dvd
             logical name: /dev/dvdrw
             logical name: /dev/sr0
             capabilities: audio
             configuration: status=open

ls -l /dev/sr0 => brw-rw----+ 1 root cdrom 11, 0 <June>   20 09:08 /dev/sr0

I'm in group cdrom

vlc -vvv /dev/sr0 output includes
libdvdnav: Using dvdnav version 6.0.1
libdvdread: Could not open /dev/sr0 with libdvdcss.
libdvdread: Can't open /dev/sr0 for reading
libdvdnav: vm: failed to open/read the DVD
dvdnav demux warning: cannot open DVD (/dev/sr0)
filesystem stream error: read error: Input/output error
cache_read stream error: cannot pre fill buffer
main stream warning: cannot insert stream filter prefetch,cache_read

The device in lsblk: sr0     11:0    1   4,1G  0 rom

sudo udisksctl unmount -b /dev/sr0 => Object /org/freedesktop/UDisks2/block_devices/sr0 is not a mountable filesystem.

No install-css.sh in /usr/share/doc/libdvdread* directories

Some errors in dmesg:

[    2.578858] kernel: sr 1:0:0:0: [sr0] scsi-1 drive
[    2.608395] kernel: sr 1:0:0:0: Attached scsi CD-ROM sr0
[   12.186835] kernel: sr 1:0:0:0: [sr0] tag#15 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[   12.186837] kernel: sr 1:0:0:0: [sr0] tag#15 Sense Key : Illegal Request [current] 
[   12.186839] kernel: sr 1:0:0:0: [sr0] tag#15 Add. Sense: Unaligned write command
[   12.186842] kernel: sr 1:0:0:0: [sr0] tag#15 CDB: Read(10) 28 00 00 20 9a ec 00 00 02 00
[   12.186844] kernel: blk_update_request: I/O error, dev sr0, sector 8547248 op 0x0:(READ) flags 0x80700 phys_seg 1 prio class 0

EDIT 2: Some kind of progress? A DVD that was in the computer when booting up was automatically mounted under /media, I could ls its content, and I got "Can't open main ifo!" from lsdvd. Then I tried eject, and it kind of worked, closing the tray immediately after it opened.

After that, the DVD wouldn't mount anymore. After booting I have "Can't find device /dev/dvd" from lsdvd, and /dev/dvd doesn't exist.

Looks like the DVD drive is now considered "open" regardless of its actual state. lshw says configuration: status=open, and also:

setcd -i /dev/sr0 
/dev/sr0:
  CD tray is open
setcd -s /dev/sr0 
/dev/sr0:
  Auto close tray:     cleared
  Auto open tray:      cleared
  Use O_NONBLOCK flag: set
  Lock tray:           cleared
  Check CD type:       cleared

eject -t gives an I/O error regardless of the tray's state, and eject -T tries to close it, giving an I/O error.

setcd -f0 /dev/sr0
eject -v -t /dev/sr0
setcd -r /dev/sr0

...and a reboot:

setcd -i /dev/sr0 
/dev/sr0:
  Disc found in drive: data disc type 1
setcd -s /dev/sr0 
/dev/sr0:
  Auto close tray:     set
  Auto open tray:      cleared
  Use O_NONBLOCK flag: set
  Lock tray:           cleared
  Check CD type:       cleared
lsdvd 
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
Can't open disc /dev/dvd!
setcd -i /dev/sr0 
/dev/sr0:
  CD tray is open

lsdvd changed it to "open" again?!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.