5

On my Ubuntu 22.04 LTS (installed on an ASUS ZenBook with Intel i5 11th gen), I get a weird thing happening.

Every time I try to do something a bit more heavy, like image opening more apps at the same time, Ubuntu freezes (the mouse stops working and UI is frozen).

The fan starts going but never too much, and the weird thing is that is just frozen: no access to ttys as well, I can only force shutdown with power button.

If I try and check with journalctl the last session logs, I always find random/normal stuff, but nothing that is always the same or indicates any specific reason.

Any suggestion on what could be and how I can investigate this after a forced reboot?

UPDATE: after trying many things, I investigated more into memory and swap, and because I use zfs with a zvol partition for swap, I arrived to this page https://github.com/openzfs/zfs/issues/7734 and I was able to re-create the issue using stress-ng sending big amounts of pages into RAM and so triggering big amounts of swap...system frozen!

So the problem is described in that 4 years old issue (absurd that Ubuntu still offers zfs!)...if you need performance with lots of potential use of swap, do not use zfs, as it's not maintained and is not working properly with swap.

I posted about this in another different topic: Ubuntu 22.04 LTS with zfs filesystem and swap: deadlock! How to solve?

13
  • It can be a hardware problem.
    – Pilot6
    Jun 18, 2022 at 13:32
  • For a test, try disabling turbo CPU frequencies. Assuming you are using the intel_pstate CPU frquency scaling driver then echo "1" | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo. See also here. Jun 18, 2022 at 14:19
  • Just as a test, I used stress-ng with following command (quite punishing for my Zenbook UX425ea with an i5 11th Gen and 8GB of ram): stress-ng --cpu 4 --io 4 --vm 4 --vm-bytes 1G --timeout 30s --metrics-brief (it all worked perfectly and didn't freeze)
    – opoloko
    Jun 18, 2022 at 15:33
  • @DougSmythies I tried, no change, it just freezes.
    – opoloko
    Jun 18, 2022 at 15:58
  • Try this: stress-ng --cpu N --cpu-method matrixprod where "N" is the number of CPUs that you have in your processor. Jun 18, 2022 at 15:58

0

You must log in to answer this question.

Browse other questions tagged .