12

When I download something with Google Chrome, the browser gets stuck (it shows the hand pointer as it hovers over an link/button).

It's not frozen, as I can move and resize the window freely, but I cannot click on anything and shortcuts don't work either.

Can close it with Alt+F4.

This happens on a fresh install of Ubuntu 22.04.

So far the issue

  • seems to happen when the browser asks for the save location of a file or an import dialog
  • is independent of extensions
  • is independent if a Google account is connected, or sync enabled
  • affects all Chromium-based browsers, tested so far: Chrome, Opera, Vivaldi, Brave
13
  • please post debug info.run Chrome from the command line and post the debug info here.
    – Rishon JR
    Jun 18, 2022 at 12:53
  • Hi Rishon, how can I do that? The log disconnects after Chrome starts.
    – adi
    Jun 18, 2022 at 13:01
  • Hi, follow this article: support.google.com/chrome/a/answer/6271282?hl=en#zippy=%2Clinux
    – Rishon JR
    Jun 21, 2022 at 9:08
  • The log generated is to big to paste it inside this comment and astebin has a limitation of 512KB which of course it exceeds it.
    – adi
    Jun 21, 2022 at 13:23
  • Even if I remove all log before the download happens it still goes around 900KB.
    – adi
    Jun 21, 2022 at 13:23

4 Answers 4

5

This worked for me:

sudo apt install xdg-desktop-portal-gnome

Explanation:

Google Chrome freeze uploading a file

https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1970148

2
  • Thanks for your answer, though I changed the distro on my machine though, so I cannot test your answer. That's why I will keep my answer since that also worked.
    – adi
    Sep 5, 2022 at 11:42
  • Can confirm, this command fixed my chrome freezing issue on ubuntu 22.04 Oct 14, 2022 at 8:47
3

Ok so the issue is Nvidia driver 510.

After bumping into the same issue as the one asked about in Steam will not run at all, no matter what I do. (22.04 LTS) I thought the solution could help with this issue as well.

What made me think this was the case was that the browser didn't freeze but I couldn't interact with it at all; the browser was working (for example: if it was a big download the download loader was running, not freezing). And the issue occured whenever a dialog from browser was opened (download, import, print, etc.).

So if anyone encounters this issue and has Nvidia driver 510, downgrade to 470 and see if it works.

1
  • 1
    Same issue with 515
    – mktplus
    Sep 18, 2022 at 14:58
0

My resolve is delete directory rm -rf ~/.config/google-chrome.

1
  • Hi @La An Vong, thanks for answering but this was my first try and wasn't something which helped.
    – adi
    Oct 25, 2022 at 7:13
0

Extending other answers and some additional thing I did worked for me:

  • sudo apt install xdg-desktop-portal-gnome

  • turn off hardware acceleration

    • Go to chrome settings > search Hardware in the search box > and Hardware acceleration > Turn it off
  • Reboot the PC

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.