I have the following Problem:

For several hours now I am trying to get TES 4 Oblivion to run on Ubuntu with no luck at all. The Launcher starts just fine but it just refuses to recognize the Nvidia GPU. I am sure however that all other programs work fine with the Nvidia CPU because the Game crashes on startup, which it didn't do before I changed the Prime Profile to Nvidia (Performance Mode) (which should make it so that all Application run with the Nvidia GPU, correct?).
Now Oblivion is notorious for this Problem in particular on Notebooks as it produces the same error on Windows, but there its an easy Problem to fix because you can just manually tell it to use the Nvidia GPU from the Nvidia Control Panel which isn't an option for Ubuntu.

Troubleshooting Information:

sudo lshw -C video

       description: VGA compatible controller
       product: Haswell-ULT Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       logical name: /dev/fb0
       version: 0b
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=i915 latency=0 resolution=1600,900
       resources: irq:51 memory:b5000000-b53fffff memory:c0000000-cfffffff ioport:6000(size=64) memory:c0000-dffff
       description: 3D controller
       product: GM108M [GeForce 830M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:0a:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:54 memory:b3000000-b3ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:3000(size=128)

sudo lsmod | grep nvidia

vidia_uvm           1216512  0
nvidia_drm             69632  10
nvidia_modeset       1159168  6 nvidia_drm
nvidia              39112704  450 nvidia_uvm,nvidia_modeset
drm_kms_helper        307200  2 nvidia_drm,i915
drm                   606208  15 drm_kms_helper,nvidia,nvidia_drm,i915,ttm

sudo nvidia-smi

Thu Jun 16 23:27:59 2022       
| NVIDIA-SMI 510.60.02    Driver Version: 510.60.02    CUDA Version: 11.6     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:0A:00.0 Off |                  N/A |
| N/A   49C    P0    N/A /  N/A |    223MiB /  2048MiB |      9%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      1653      G   /usr/lib/xorg/Xorg                 60MiB |
|    0   N/A  N/A      1914      G   /usr/bin/gnome-shell               26MiB |
|    0   N/A  N/A      2424      G   ...2/usr/lib/firefox/firefox      131MiB |
|    0   N/A  N/A      5988      G   /usr/bin/nvidia-settings            0MiB |

sudo inxi -Gx

  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel bus-ID: 00:02.0
  Device-2: NVIDIA GM108M [GeForce 830M] vendor: Hewlett-Packard
    driver: nvidia v: 510.60.02 bus-ID: 0a:00.0
  Device-3: Chicony HP Truevision HD camera type: USB driver: uvcvideo
    bus-ID: 1-1.3:3
  Display: server: X.Org v: driver: X: loaded: modesetting,nvidia
    unloaded: fbdev,nouveau,vesa gpu: i915 resolution: 1600x900~60Hz
  OpenGL: renderer: NVIDIA GeForce 830M/PCIe/SSE2 v: 4.6.0 NVIDIA 510.60.02
    direct render: Yes

Error Message in Terminal when the game crashes:

Game process updated : AppID 22330 "/home/sadomessiah/.steam/debian-installation/ubuntu12_32/reaper SteamLaunch AppId=22330 -- '/home/sadomessiah/.steam/debian-installation/steamapps/common/SteamLinuxRuntime_soldier'/_v2-entry-point --verb=waitforexitandrun -- '/home/sadomessiah/.steam/debian-installation/steamapps/common/Proton 7.0'/proton waitforexitandrun  '/home/sadomessiah/.steam/debian-installation/steamapps/common/Oblivion/OblivionLauncher.exe'", ProcID 24257, IP
MESA-INTEL: warning: Haswell Vulkan support is incomplete
MESA-INTEL: warning: Haswell Vulkan support is incomplete
Fossilize INFO: Overriding serialization path: "/home/sadomessiah/.steam/debian-installation/steamapps/shadercache/22330/fozpipelinesv6/steamapprun_pipeline_cache".
wine: Unhandled page fault on read access to 00000880 at address 00497E10 (thread 0170), starting debugger...
ThreadGetProcessExitCode: no such process 24293
pid 24156 != 24155, skipping destruction (fork without exec?)
ThreadGetProcessExitCode: no such process 24223
ThreadGetProcessExitCode: no such process 24191
ThreadGetProcessExitCode: no such process 24185
ThreadGetProcessExitCode: no such process 24174
ThreadGetProcessExitCode: no such process 24165
ThreadGetProcessExitCode: no such process 24162
ThreadGetProcessExitCode: no such process 24154
ThreadGetProcessExitCode: no such process 24152
Game process removed: AppID 22330 "/home/sadomessiah/.steam/debian-installation/ubuntu12_32/reaper SteamLaunch AppId=22330 -- '/home/sadomessiah/.steam/debian-installation/steamapps/common/SteamLinuxRuntime_soldier'/_v2-entry-point --verb=waitforexitandrun -- '/home/sadomessiah/.steam/debian-installation/steamapps/common/Proton 7.0'/proton waitforexitandrun  '/home/sadomessiah/.steam/debian-installation/steamapps/common/Oblivion/OblivionLauncher.exe'", ProcID 24257 
ThreadGetProcessExitCode: no such process 24257
ThreadGetProcessExitCode: no such process 23981
ThreadGetProcessExitCode: no such process 23980
Game 22330 created interface STEAMAPPS_INTERFACE_VERSION003 / Apps
Game 22330 created interface SteamUtils004 / Utils
Game 22330 method call count for IClientAppManager::BIsDlcEnabled : 1
Game 22330 method call count for IClientUtils::RecordSteamInterfaceCreation : 2
Game 22330 method call count for IClientUtils::GetAppID : 3
Game 22330 method call count for IClientUser::BIsSubscribedApp : 1
Uploaded AppInterfaceStats to Steam

Wayland Protocol is disabled
I have already run sudo prime-select nvidia (+reboot)
nouveau is blacklisted according to gpu-manager.log
I have also reinstalled the nvidia drivers (+reboot)
I also tested to run the game again with PRIME Profile: Nvidia On-Demand. The game was able to start (because it can use the Intel GPU now I guess) but it didn't run when I changed it back to nvidia only.

After further troubleshooting I now found out that despite ubuntu and all the Terminal Commands showing that the nvidia card is up and running it appears that the nvidia module is missing, despite having installed the drivers multiple times:

sudo optirun glxgears

[  125.640717] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "nvidia" (module does not exist, 0)

[  125.640759] [ERROR]Aborting because fallback start is disabled.

I am currently trying to resolve this but any help would be greatly appreciated as I am relatively new to Linux.

System Information:

  • OS: Ubuntu 22.04 LTS 64-bit
  • GNOME Version: 42.1
  • Windowing System: X11
  • Proton: 7.0-3
  • Processor: Intel Core i3-4030 CPU @ 1.90GHz x 4
  • Graphics: NVIDIA Corporation GM108M [GeForce 830M]/NVIDIA GeForce 803M

I really hope someone can help me with this Problem as I really want to play this game and my only option is this Ubuntu Notebook for the next months.

Thank you all in advance!

  • You need to reboot after selecting the Nvidia profile. Did you? Jun 16, 2022 at 22:35
  • And you should read and understand this: appdb.winehq.org/… Jun 16, 2022 at 22:37
  • @ChanganAuto so I read whats written there and it just tells me that the steam version wont run on this version of ubuntu (or at least its untested). You no, not acceptable. The only other thing I get from this is that it needs a really old version of wine (3.0) but how do I downgrade. I needed to do a seperate installation of wine because proton for whatever reason never installed the Terminal Commands for it but I needed to make changes in the registry because all option in the launcher were grayed out.
    – Blackthorn
    Jun 17, 2022 at 4:44
  • @ChanganAuto of course I rebooted
    – Blackthorn
    Jun 17, 2022 at 5:15
  • I now removed wine and use the newest Proton Version (7.0-3) as it should work according to ProtonDB but it still doesn't recognize the NVIDIA GPU and when I hit "play" in the launcher it instantly crashes (probably because its expecting the Intel GPU to be there but it isn't). What else should I do? The Intel GPU is too weak to run Oblivion so I need it to be run from the NVIDIA GPU. Is noone willing to help?
    – Blackthorn
    Jun 17, 2022 at 12:07

1 Answer 1


So I have a semi-solution for this but it isn't ideal and I still need help with this Problem but I am posting this as an Answer as to not make the Question look too convoluted:

I have given up on trying to get nvidia PRIME to run because it just refuses to. It simply doesnt work, period. So I looked into alternatives and found Bumblebee (Optirun and primusrun). With the newest driver they both didnt work as shown in my previous comment as they are failing to load the nvidia module. I found this: https://github.com/Bumblebee-Project/Bumblebee/issues/526 and changed the xorg.conf.nvidia and bumblebee.conf accordingly, however it still produced the same problem. I noticed however that the thread was a bit old and since I am using an old graphics card myself I completely removed everything nvidia and bumblebee related and completely reinstalled the nvidia drivers but an older version of them (390). Tried the changes to the config again and I still got the same error.
I then found this thread: https://github.com/Bumblebee-Project/Bumblebee/issues/951 and changed the config files again but to no avail. However, further down this thread (8th answer) I found a solution to at least get primusrun (sudo primusrun Application) working by basically patching the script that runs the terminal command to point it to the correct library and now the command at least doesn't return an error and run glxgears just fine. Even Oblivion will start now (after changing the launch options in steam accordingly) and, while it runs like crap, it runs with less problems than before when using the On-demand PRIME Profile (The tree were flickering etc.). I am unsure however if it is actually using the NVIDIA GPU as the options menu in the launcher still only shows the Intel GPU, so I still require help with this issue and I would greatly appreciate if someone more knowledgeable about Linux than me could help me with this problem as I also think other people could benefit from this.

Thanks in advance.

  • After a reboot of the system the game wont work at all again. I am starting to think that Linux as a whole is a really bad OS. They propably dont even know what usability means...
    – Blackthorn
    Jun 18, 2022 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.