I have installed Ubuntu 12.04 on Dell Vostro 1520 Laptop. But found Wifi is hardware locked, though wifi is working perfectly fine with Windows 7 in the same laptop.

I tried to upgrade the drivers as mentioned in other posts/forums but could not resolve the issue.

I had the similar problem with versions 11.* as well. Last time the Wifi worked with 10.* version.

Please help me to get it resolved.

  • 2
    Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. May 24, 2012 at 0:18

3 Answers 3


I have a Vostro 1520 on which I just upgraded to 12.04. Even though my wifi was working on 10.04, I have to re-do what I've done on 10.04... Here it is:

sudo rmmod dell_laptop

At this point, wireless indicator will light up and after a while, you'll be able to connect to the available wi-fi access points. However, the dell_laptop kernel module will get loaded again on bootup and hence, the fix is not permanent. Let's make it so:

echo 'blacklist dell_laptop' | sudo tee /etc/modprobe.d/blacklist-custom

Wireless should be working fine from now on.

It did on my laptop.

Hope this helps!


I had a hard time making the WiFi work after installing Ubuntu 12.10 on Dell XPS. Running rfkill list all always returned:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

After trying almost everyone of the tons of suggestions about this problem on the Ubuntu forums, and none of them worked form, I simply tried Fn+F2 (the F2 key has the WiFi sign) and the problem disappeared.

The simple solution (unless you have a deeper problem) is Fn+F2 (or whatever key with the WiFi sign).


I also faced the same problem when upgraded to 11.10. I tried the auto updating using the hard line -ethernet cable - , but didn't work. After some research I finally made it. In the end, these commands made my day.

To make this work, your must be connected to Internet, so use LAN cable.

sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source
sudo apt-get install b43-fwcutter firmware-b43-installer

Then reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.