0

I'm trying to install Ubuntu server automatically in Hyper-V from this iso: ubuntu-22.04-live-server-amd64.iso I use the VOLUME method to pass the cloud-init cfg so I have created a seed.iso loaded in a second virtual-dvd-drive for the autoinstall (the first dvd holds the live-server.iso).

This is the view of the VM screen on the hypervisor. output in hypervisor

I also have the crash file but it's quite large so I'll have to link it crash report file. But this is the main error in the crash report: FAIL: no identity data provided. I tried adding "" around the crypted Password: in case the $ in the string would confuse some interpreter, but that didn't help. So I don't know why it claims that there is no identity.

 2022-06-14 05:53:23,647 ERROR root:39 finish: subiquity/Identity/apply_autoinstall_config: FAIL: no identity data provided
 2022-06-14 05:53:23,647 ERROR root:39 finish: subiquity/apply_autoinstall_config: FAIL: no identity data provided
 2022-06-14 05:53:23,647 ERROR subiquity.server.server:416 top level error
 Traceback (most recent call last):
   File "/snap/subiquity/3359/lib/python3.8/site-packages/subiquity/server/server.py", line 625, in start
     await self.apply_autoinstall_config()
   File "/snap/subiquity/3359/lib/python3.8/site-packages/subiquitycore/context.py", line 148, in decorated_async
     return await meth(self, **kw)
   File "/snap/subiquity/3359/lib/python3.8/site-packages/subiquity/server/server.py", line 467, in apply_autoinstall_config
     await controller.apply_autoinstall_config()
   File "/snap/subiquity/3359/lib/python3.8/site-packages/subiquitycore/context.py", line 148, in decorated_async
     return await meth(self, **kw)
   File "/snap/subiquity/3359/lib/python3.8/site-packages/subiquity/server/controllers/identity.py", line 60, in apply_autoinstall_config
     raise Exception("no identity data provided")
 Exception: no identity data provided

I use the user-data for the config & I have a 0 byte meta-data file (empty but there).

Here is the content of my user-data. I have tried multiple combination update yes-no and different apt sources and they all end the same way with the crash of subquity. I started with my own config, but I've converged to your example here: https://ubuntu.com/server/docs/install/autoinstall to try to eliminate underlying problems I could have introduced.

Kind Regards, Martin Politick. June 2022.

user-data

#cloud-config
autoinstall:
  version: 1

#early-commands:
#    - ping -c1 198.168.10.2
locale: en_US.UTF-8
refresh-installer:
  update: yes
keyboard:
    layout: us
    variant: ""
network:
    network:
        version: 2
        ethernets:
            eth0:
               dhcp4: yes
#proxy: http://squid.internal:3128/
apt:
    preserve_sources_list: true
    primary:
        - arches: [default]
          uri: http://repo.internal/
#        - arches: [i386, amd64]
#          uri: "http://archive.ubuntu.com/ubuntu"
#        - arches: [default]
#          uri: "http://ports.ubuntu.com/ubuntu-ports"
#    geoip: true

#    sources:
#        my-ppa.list:
#            source: "deb http://ppa.launchpad.net/curtin-dev/test-archive/ubuntu $RELEASE main"
#            keyid: B59D 5F15 97A5 04B7 E230  6DCA 0620 BBCF 0368 3F77
storage:
    layout:
        name: lvm
identity:
    hostname: gold
    username: wenco
    password: $6$e8JJnlcSYAlKfoQ9$BlEJxE0ToJzT3Ic1NJjsjPm87zyN./1faw32/TQnj9z6GTobR/r6Tn2q0OsESmZfC3ieeNokupExLvGEe.zOp.
ssh:
    install-server: yes
    authorized-keys:
      - ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABgQCOhTzmJeZlCSsEDo4ye9uDXbQK/SIokfpfQZ86Se+2lfODn2A+aeZVBbnL5eDZXd/DxgjsvrsQu7Lzbk/WTkzkaPofmQxGGUYkTjI8u7yBggPbdfeW7cDcH6eEFAIIcHVmNd+/ecX+9HWtzrjBA8ctDa4DhcfvcSJWrfBIpazpI7FrTEJLJqcsyDLtNUkRdn5QL29r4bIiiGaNen2AwVRPPG7vcot8XDFBS4I5og6KmtGpt5MwNHn8mrGnKaUEMtxAJqCA5LWREXi306iBMgK9xFHeYJaQEKei+BzC7Ab1NI+tQYMm874O8ca9fCZHnS46B661lugDRwAu6SxyICIY6QKqW3Ylh1KjVeu1Ww978ZEQ5whICRJnQ345Q90qs+ToZob3XOdk1p4f3XboE3MtAFPyU32neQ60j68RAZDtg7ZNDAKavfg0507TX2AtberTtJUhCUZSnavONWmJJWd3CV3Fap8TiidcwbZVn1kZPjwnJfTP4PczkZm91e/K+K0=
    allow-pw: no
#snaps:
#    - name: go
#      channel: 1.14/stable
#      classic: true
#debconf-selections: |
#    bind9      bind9/run-resolvconf    boolean false
packages:
    - curl

user-data:
    disable_root: false
late-commands:
    - sed -ie 's/GRUB_TIMEOUT=.*/GRUB_TIMEOUT=5/' /target/etc/default/grub
#error-commands:
#    - tar c /var/log/installer | nc 192.168.0.1 1000
reporting:
 builtin:
  type: print

CRASH FILE

It does not fit here ... You should be able to get it here: https://wiki.politick.ca/download/attachments/49905696/1655186003.648901463.unknown.crash?version=1&modificationDate=1655188041577&api=v2

link to creah report file

4
  • Did your user-data post properly? If it is accurate then you are missing a lot of indentation. Jun 14 at 22:12
  • Once in the crash prompt, I can cloud-init query userdata and I see the output of the user-data above. cloud-init status also says status: done. Also /var/log/cloud-init-output.log finished with a modules-final: SUCCESS: running modules for final Jun 14 at 22:18
  • All of the keys used for autoinstall need to be indented under the autoinstall block like your version key. Look at sample user-data files to see examples of how the keys are formatted. Jun 14 at 22:34
  • Yes... # echo $( removeProfanityMacro( $Comment )) The indentation was the problem. This is why I hate yaml so intensely. I even tried cloud-init devel schema user-data and it returned valid... Jun 14 at 23:01

1 Answer 1

0

Problem

The yaml indentation is wrong.
All the autoinstall key:value pairs must be placed under the autoinstall scope.

How it happened

I've cut & pasted the example here : https://ubuntu.com/server/docs/install/autoinstall which is missing the top scope autoinstall. Because of that the indentation of the example is wrong if you just cut & paste the content.

But I do thank Andrew Lowther for helping me ! Thx Andrew !

Kind Regards, Martin Politick, June 2022

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.