0

I'm trying to install wine on Ubuntu 22.04. I followed the instructions here: https://wiki.winehq.org/Ubuntu. Here is what I tried:

$ sudo apt install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 7.0.0.0~bullseye-1)
E: Unable to correct problems, you have held broken packages.
$ sudo apt install wine-stable
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-stable-amd64 : Depends: libldap-2.4-2 (>= 2.4.7) but it is not installable
                     Recommends: libodbc1 but it is not going to be installed
                     Recommends: libosmesa6 but it is not going to be installed
 wine-stable-i386:i386 : Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not installable
                         Recommends: libcups2:i386 but it is not going to be installed
                         Recommends: libglu1-mesa:i386 but it is not going to be installed or
                                     libglu1:i386
                         Recommends: libodbc1:i386 but it is not going to be installed
                         Recommends: libosmesa6:i386 but it is not going to be installed
                         Recommends: libsdl2-2.0-0:i386 but it is not going to be installed
                         Recommends: libv4l-0:i386 but it is not going to be installed
                         Recommends: libxcomposite1:i386 but it is not going to be installed
                         Recommends: libxcursor1:i386 but it is not going to be installed
                         Recommends: libxfixes3:i386 but it is not going to be installed
                         Recommends: libxi6:i386 but it is not going to be installed
                         Recommends: libxinerama1:i386 but it is not going to be installed
                         Recommends: libxrandr2:i386 but it is not going to be installed
                         Recommends: libxxf86vm1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
$ sudo apt install libldap-2.4-2
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package libldap-2.4-2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libldap-common

E: Package 'libldap-2.4-2' has no installation candidate

I already have libldap-common:

$ sudo apt install libldap-common
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
libldap-common is already the newest version (2.5.11+dfsg-1~exp1ubuntu3.1).
libldap-common set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Here are possible installation candidates I found using tab tab:

$ sudo apt install libldap
libldap-2.5-0      libldap-common     libldap-java       
libldap2-dev       libldap-dev        libldap-ocaml-dev  

I already have libldap-2.5-0, but I don't know how to go down to libldap-2.4-2.

$ sudo apt install libldap-2.5-0
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
libldap-2.5-0 is already the newest version (2.5.11+dfsg-1~exp1ubuntu3.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Can anyone help me download wine?

6
  • 4
    The instructions are, as always, install it from the official Ubuntu repository, NOT from anywhere else. Simply run sudo apt install wine. Jun 12, 2022 at 0:04
  • Oh that was the issue thanks.
    – Chris Z
    Jun 12, 2022 at 0:12
  • 1
    Does this answer your question? How do I resolve unmet dependencies after adding a PPA?
    – karel
    Jun 17, 2022 at 7:23
  • @ChanganAuto, the official Ubuntu repository for the LTS releases is eternally stuck on 15+ month old releases. The 6.0 branch in 22.04 was released in January 2021, and may not be good enough for a large number of users.
    – jbo5112
    Nov 20, 2022 at 2:45
  • @jbo5112 It's good enough for 99%+ of users AND software. And, if you're in those 1% and actually "need" a newer version you can install PlayOnLinux and with it install newer, current or older versions and manage them via bottles. Nov 20, 2022 at 8:05

1 Answer 1

0

It stinks that Ubuntu 22.04 is stuck with the January 2021 release wine 6.0. You may need the newer WineHQ version for a number of different games.

Your system is missing 32-bit versions a number of common packages that wine requires. It normally should be missing these, but much Windows is still stuck in 32-bit land. Make sure that i386 is enabled, and you have the package entries.

dpkg --add-architecture i386
apt update

A documented issues on 22.04 is with KDE Neon the libpoppler-glib8 dependency is broken. The solution is sudo apt install libpoppler-glib8:{i386,amd64}=22.02.0-2ubuntu0.1. Other third-party repositories may be broken (usually by not supporting i386), but there are too many repos to go through them all.

WineHQ may have additional documented issues at a later point: https://wiki.winehq.org/Ubuntu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.