1

On my old but light travel laptop I had Debian and Windows 7, which I could both boot from GRUB. I have replaced Debian with Kubuntu, but now booting Windows 7 from GRUB results in a black screen.

On thing I remember that I had to do installing GRUB after Windows, was to map the Windows partition as if it is the first on the disc. Adding these commands

drivemap -s (hd0) ($root)
chainloader +1

to the boot entry for Windows, I ended up at this screen (summary):

                            Windows Boot Manager

A recent hardware or software change might have installed a file that is signed
incorrectly or damaged, or that might be malicious software from an unknown 
source.      

If you have a Windows installation disc, insert the disc and restart your 
computer. Click “Repair your computer“, and then choose a recovery tool.

Otherwise, to start Windows you can investigate further, press the ENTER key 
to display the boot menu, press F8 for Advanced Boot Options, and select Last 
Known Good. If you understand why the digital signature cannot be verified and
want to start Windows without this file, Temporarily disable driver signature
enforcement.

File: \Windows\System32\winload.exe

Status: 0xc0000428

Info: Windows cannot verify the digital signature for this file.

After that, I can do a memory check but there are no other options than boot Windows and return to this screen. Because this is after GRUB (and I want to keep it there) I think the F8 option, or using a Windows disc, are not possible. I can mount the Windows file system in Linux, if anything needs to be done to C:\Windows\System32\winload.exe

Does anyone know if this can be fixed before getting into Windows? For example, I put those 2 commands in the boot entry, but maybe other lines need to be deleted?

3
  • 1
    You do know Windows 7 is out of support and definitely should not be connected to Internet. Grub only boots working Windows. And old BIOS installs only have one MBR (unless you have two drives), so you have to temporarily reinstall the Windows boot loader to MBR with your Windows repair disk, fix Windows, and then restore grub to MBR with Ubuntu live installer. That may be easier with Boot-Repair in live installer, but can be just mount / & reinstall grub. help.ubuntu.com/community/Boot-Repair & sourceforge.net/p/boot-repair/home/Home
    – oldfred
    Jun 10, 2022 at 14:26
  • Thanks @oldfred -- I just have win7 on that laptop because it was always on there. And it was working before In installed Kubuntu over Debian (i.e. overwriting /, /usr, /boot and swap, leaving my /home intact. That has worked before with different Debian versions? I think if I make the drivemap command permanent, it will always boot to win7. I'm just not sure why after booting it would report that winload problem.
    – alle_meije
    Jun 13, 2022 at 15:32
  • Most desktops do not need separate partitions for /usr & /boot. And now Ubuntu uses swap file, so swap partition is optional. I also do not use separate partition for /home, but do have partitions for data, so /home is tiny (mostly just hidden settings). Please copy & paste the pastebin link to the Bootinfo summary report ( do not post report), do not run the auto fix till reviewed.Lets see details, use ppa version with your USB installer (2nd option) or any working install, not Boot-Repair ISO help.ubuntu.com/community/Boot-Repair
    – oldfred
    Jun 13, 2022 at 15:54

0

You must log in to answer this question.

Browse other questions tagged .