I recently bought Alienware X15 r2, hoping to dual boot Ubuntu on a separate SSD (with windows 11) and leverage the GPU for ML work. I was able to install Ubuntu 22.04 LTS, the basic version however could not connect to the internet - 'no wifi adapters found' and ethernet is not working as well.

I have tried installing Ubuntu 20.04 - installation did not work. Based on what I found on the internet, I believe that this version of Alienware has an Intel alder lake processor and wifi adapter which is relatively new and is not optimised yet.

Tried connecting external ubuntu compatible wifi adapters - did not work.

Any suggestion/ recommendations would be highly appreciated. I am new to Linux - so not very experienced, please suggest.

Output for lspci -knn | grep Net -EA3; rfkill list

(standard input):00:14.3 Network controller [0280]: Intel Corporation Alder Lake-P PCH CNVi WiFi [8086:51f0] (rev 01)
(standard input):   Subsystem: Rivet Networks Device [1a56:1672]
grep: EA3: No such file or directory
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no


You must log in to answer this question.

Browse other questions tagged .