4

I successfully followed instructions in https://wiki.ubuntu.com/LiveUsbPendrivePersistent to make a bootable usb drive for ubuntu12.04 using the command 'gksudo usb-creator-gtk' in a terminal window - there were no error messages and the final pop message said I can now use the USB drive to successfully boot a system into the latest Ubuntu 12.04

However, on a brand new samsung laptop (NP-300E5Z-A0PIN - a i5 core machine), I get the following message: SYSLINUX 3.63 Debian-2008-07-15 EBIOS Copyright (c)1994-2008 H Peter Anvin Unknown keyword in configuration file Boot:

It hangs there...

Am I missing out any steps... how do I proceed with the installation... Many thanks in advance

2
  • This also happened when I tried booting on a ACER aspire 4710 laptop that I run an older version of ubuntu (and on which I made this bootable USB drive)
    – Drake
    May 23, 2012 at 18:01
  • Did you check the md5sum of the iso ? help.ubuntu.com/community/HowToMD5SUM
    – Panther
    May 23, 2012 at 18:21

3 Answers 3

13

I found this site, hopefully this will help you. Click Here

Below is the solution from that site:

After creating a USB bootable version of Ubuntu from the Startup Disk Creator (or usb-creator-gtk) and attempting to boot, I was greeted by the error above. It might look a bit scary but it’s really easy to fix, just plug the USB flash drive into a computer (windows or linux, mac too probably but I haven’t tried that.)

Solution 1:

Open the the syslinux folder in the root of the flash drive.
Inside is a file called syslinux.cfg you’ll want to edit that.
Find the line “ui gfxboot bootlogo” and simply remove the “ui “.
Save and try booting again.

Below is how my syslinux.cfg file looks after editing:

# D-I config version 2.0
include menu.cfg
default vesamenu.c32
prompt 0
timeout 50
gfxboot bootlogo

Solution 2

Alternatively it looks as though there is another way of fixing this issue if there is no “ui” in the file, this is to do as followed (as pointed out in the comments below):

Type “help” and press enter
Hit Enter again

This should boot correctly and shouldn’t need to be done every time.

Source: http://alexsleat.co.uk

2
  • Thanks a lot.... it worked.... Guess the original distribution should have been fixed long back....
    – Drake
    May 24, 2012 at 2:52
  • Solution 2 worked perfectly! Thanks! Jun 13, 2015 at 17:14
3

The problem is that usb-creator depends on syslinux-legacy 3.63, and uses it to write boot up informations into USB, while the parameters "ui" can only be accepted by syslinux 4.05, which was installed on ubuntu 12.04.

A simple solution to solve everything is:

sudo mv /usr/bin/syslinux-legacy /usr/bin/syslinux-legacy.bak
sudo ln -s /usr/bin/syslinux /usr/bin/syslinux-legacy

And you can actually use syslinux 4.05 to write boot information into USB.

1
  • I used usb-creator many times, This problem wasn't there. It may not be the main cause.
    – Anwar
    Sep 23, 2012 at 4:07
0

I got the same message when installing Arch Linux (last release, around July 2018) and what I got is: SYSLINUX 4.07 EDD 2013-07-25 Copyright (C) 1994-2013 H. Peter Anvun et al No child node, aborting Unknown keyword in configuration file: PATH boot/syslinux/whichsys.c32: not a COM32R imagw boot:

I made the usb drive using a pointed usb creator (linked in Linux Mint's site, lol). I tried using the above answers, but nothing happened to work, neither there is command help, so what i did is hit TAB and i got three commands listed - select (didn't do anything), pxe (it started the GUI installation, so it works well) and sys (which also acts like pxe, but gives a little bit different options). Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.