0

Iam using Ubuntu 18.04.6 LTS and I run the following

sudo apt update
sudo apt upgrade
sudo reboot

After that there is no sound coming out from speakers and its showing Dummy Output as a sound output device.

I added the following in etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=generic
options snd-hda-intel dmic_detect=0

and added below in /etc/modprobe.d/blacklist.conf

blacklist snd_soc_skl

After restarting sound worked. I shutdown the computer and restarted again. Now there is no sound

2

2 Answers 2

0

I had the same issue.

This no sound in Ubuntu fix works if your computer is using the snd_hda_intel kernel module. So before attempting to apply this fix, check out to see if the snd_hda_intel kernel module is in use. For this you can run:

lsmod | grep snd_hda_intel

Which should display at least one snd_hda_intel entry. Here's the output from my computer:

$ lsmod | grep snd_hda_intel
snd_hda_intel          40960  8
snd_hda_codec         126976  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           81920  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_pcm                98304  4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
snd                    81920  27 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_seq_device,snd_hda_codec_realtek,snd_pcm

You can also run:

lspci -nnk | grep -A2 Audio

Which should display the audio devices along with the kernel module / driver in use. This is the output from my system:

$ lspci -nnk | grep -A2 Audio
00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20] (rev 05)
Subsystem: Dell 6 Series/C200 Series Chipset Family High Definition Audio Controller [1028:04a7]
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
  1. If you do get snd_hda_intel in the output of the above commands, and you get no sound (and only a Dummy Output) in Ubuntu, here's what you can try to fix it. You need to add options snd-hda-intel model=generic at the end of the /etc/modprobe.d/alsa-base.conf file. Do not modify anything else in this file!

You can add options snd-hda-intel model=generic at the end of /etc/modprobe.d/alsa-base.conf by running this command:

echo "options snd-hda-intel model=generic" | sudo tee -a /etc/modprobe.d/alsa-base.conf

Only run this command once because it adds this line each time you run it! If you want to modify it, open /etc/modprobe.d/alsa-base.conf as root with a text editor.

  1. After this, reboot your system. Hopefully your sound now works in Ubuntu and you no longer get only a Dummy Output device in System Settings > Sound.

If you continue to get no sound output and still only see the Dummy Output in System Settings, you can try to set the model to auto instead of generic, so edit the /etc/modprobe.d/alsa-base.conf file with a text editor (as root) and change that. You can find a list of other models you can try depending on your computer hardware here.

Please refer link as it goes through a lot of reasons why you might be experiencing issues.

1
  • Alright thanks for the info @Nmath
    – Scientist
    Commented Jun 8, 2022 at 5:30
0

After reading the second answer here, I followed the link they suggested: https://www.linuxuprising.com/2018/06/fix-no-sound-dummy-output-issue-in.html but wanted to point out that one of the first, simplest solutions from that page immediately returned my audio device without rebooting: Restarting PulseAudio

pulseaudio -k

This restarted the audio system (I heard my speakers pop-on) and voila. Re-enabled sound in the system settings and good to go.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .