I am a new user to Ubuntu 22.04 as a Guest OS inside VM VirtualBox v6.1. And this is my first Ubuntu question in this forum.

I have been trying to install the rest2web package but no matter what my effort, the package installer says the package rest2web was not found. (Even including the full URL to the package download page, but still not found.) I am not sure if I am supposed to use pip3 or else apt-get, have tried both without success.

Another package, Noetic Ninjemys (ros-noetic-desktop-full) caused me similar problems being also not found, but I am told there are trusted keys involved with apt-key deprecated.

Finally I tried to add a Source Repository using "Ubuntu > Software & Updates > Other Software" but it comes back saying "E: The repository 'http://packages.ros.org/ubuntu jammy Release' does not have a release file. Updating from such a repository cannot be done securely and is therefore disabled by default." When I tried entering some other repositories there, they were not retained (saved).

I hope you can assist with these package install difficulties. Thank you.

  • 1
    Does this answer your question? What can I do if a repository/PPA does not have a Release file?
    – guiverc
    Jun 7, 2022 at 7:03
  • This isn't a forum, but a Q&A site where each question should focus on a single problem. My duplicate link focuses on a single one. rest2web is an old package that was removed (deprecated), thus is available in Ubuntu repositories only for releases up to 18.04, eg. rest2web | 0.5.2~alpha+svn-r248-2.3 | bionic/universe | source, all) so not being found for jammy (20.04) is expected (it was python2 which is EOL now causing removal if packages weren't ported to python3).
    – guiverc
    Jun 7, 2022 at 7:05
  • Does this answer your question? ROS on BeagleBone Black?
    – karel
    Jun 7, 2022 at 8:04
  • Thank you guiverc for explaining that rest2web was deprecated. My interest in the rest2web package was sincere but outdated. I was working through the textbook "Artificial Intelligence for Robotics, 2018", and it lightly mentioned the rest2web package in its text. I was trying to set up my Linux system to be the same (or similar) to the author by installing the packages he mentioned in the text. Having learned from you that rest2web is deprecated, I will just avoid installing it. Thank you.
    – kennr
    Jun 7, 2022 at 20:39

1 Answer 1


Actually we have two thirds of the question answered at this point. The last third about Ubuntu > Software & Updates > Other Software (Repositories) will have to wait until a future time when I can research Ubuntu Repository methods more thoroughly. I will try to read and study the repository info links provided by the other commenters then.

Part 1 Answer: Avoid installing the deprecated package rest2web entirely. Although it was briefly (lightly) mentioned in the author's book "Artificial Intelligence for Robotics, 2018", being since deprecated it is no longer important. Thank you guiverc for that observation.

Part 2 Answer: My interest in "noetic" began when the author of "Mastering ROS for Robotics Programming, 3rd Ed, 2021", mentioned the following: "The software needed to follow this book are ROS and Noetic Ninjemys." Consequently I mistakenly thought ROS and Noetic Ninjemys were separate entities. But not at all. Noetic Ninjemys is just an earler (than today) edition of ROS, (not separate from ROS). Today the latest stable releases are Ubuntu 22.04 (jammy) with ROS2 Humble Hawksbill, which are what I used for my system.

Thanks to all who helped with this question. Regards.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .