My laptop says "No WiFi adapter found" when I go to settings. Here is what lpsi returns:

03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:b852]

and lshw -C network:

WARNING: you should run this program as super-user.
  *-network UNCLAIMED       
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: cap_list
       configuration: latency=0
       resources: ioport:2000(size=256) memory:80500000-805fffff
       description: Ethernet interface
       physical id: b
       bus info: usb@1:1
       logical name: enxeaa730017396
       serial: ea:a7:30:01:73:96
       capabilities: ethernet physical
       configuration: broadcast=yes driver=ipheth driverversion=5.15.0-35-generic ip= link=yes multicast=yes

lsmod | grep rtw results:

rtw89pci               49152  0
rtw89core             352256  1 rtw89pci
mac80211             1228800  2 rtw89pci,rtw89core
cfg80211              958464  2 rtw89core,mac80211

modinfo rtw89pci results:

filename:       /lib/modules/5.15.0-35-generic/kernel/drivers/net/wireless/realtek/rtw89/rtw89pci.ko
license:        Dual BSD/GPL
description:    Realtek 802.11ax wireless PCI driver
author:         Realtek Corporation
srcversion:     5F18D2B3333DF111288DB86
depends:        rtw89core,mac80211
retpoline:      Y
name:           rtw89pci
vermagic:       5.15.0-35-generic SMP mod_unload modversions 
parm:           disable_clkreq:Set Y to disable PCI clkreq support (bool)
parm:           disable_aspm_l1:Set Y to disable PCI ASPM L1 support (bool)
parm:           disable_aspm_l1ss:Set Y to disable PCI L1SS support (bool)

I have checked that it is not hard-blocked in BIOS. I have tried both the rtw89 and rtw88 drivers and followed instructions for those to no avail. I also tried buying a wifi usb dongle, but cannot get that one to work with linux either.

I have a Lenovo yoga 6 13ALC7 and Ubuntu 22.04 LTS. Is there any way to get wifi on this computer?

Thank you in advance for any help!

  • Which instructions did you use? Did you use this one? Also, if you are using secure boot, the instructions have changed and I believe you should use sudo make sign-install or you could use the regular instructions and disable secure boot.
    – mchid
    Jun 6, 2022 at 0:58
  • Yes, I did follow that one, and just tried a clean and re-install. It says successful but then I still have no wifi adapter after reboot. When I ran sudo make sign-install I get the message: make: *** No rule to make target 'sign-install'. Stop.
    – Kelli
    Jun 6, 2022 at 2:08
  • More clearly, after a reboot, run lsmod | grep rtw and look for kernel modules like rtw89, if you see one listed (rtw89 for example), disable it: sudo modprobe -r rtw89 and then load the built module: sudo modprobe rtw89pci If this works, let me know and I'll give a full answer below.
    – mchid
    Jun 6, 2022 at 2:20
  • If no kernel modules are listed when you run lsmod | grep rtw then you can simply run sudo modprobe rtw89pci to load the built module. This should enable the wifi. Again, please let me know if this works and I will write a full answer below.
    – mchid
    Jun 6, 2022 at 2:22
  • 1

2 Answers 2


User @Chilli just posted an alternate driver for your particular device. Reboot before you run the commands. The answer is here, just skip the first two commands (start with sudo apt update). Also, after you run sudo make install you may need to run sudo modprobe 8852be to load the driver.

sudo apt update
sudo apt install git bc
git clone https://github.com/HRex39/rtl8852be.git
cd rtl8852be
sudo make install
sudo modprobe 8852be

Please view (and upvote) the original answer for more info and for instructions on how to recompile after a future kernel update.

  • @michael-nixon You should post the edit as an answer instead of an edit.
    – mchid
    Mar 20 at 19:36

The driver rtl8852be is obsolete, and generally inferior to the one now in https://github.com/lwfinger/rtw89.git, which parallels the code that will be in kernel 6.2 when it is released in 2-3 months. The repo https://github.com/lwfinger/rtw8852be.git will be deleted on Dec. 1.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .