0

I'm using Ubuntu 20.04 on Hyper-v 21H2 Windows Version I've followed instructions from below link : http://c-nergy.be/blog/?p=14888 and xrdp session has started (but I was only black screen) so I had to restart VM and now, Enchanced Session button is greyed out and I'm not asked to log into xrdp anymore.

I've checked xrdp and xrdp daemon is actve and running. I've also run Set-VM -VMName "Ubuntu 20.04" -EnhancedSessionTransportType HvSocket again but it did not helped.

1 Answer 1

0

Just a guess here.... have you enabled the Enhanced mode settings at the Hyper-V server ? If the setting is not enabled on the Hyper-v server, the option in the vm console will be greyed out..

To check, please do the following

  1. open your Hyper-V MMC console
  2. in the right side menu; select the Hyper-V settings option
  3. go to Enhanced Mode Node and ensure that Enhanced Mode Policy is enabled
  4. Boot your VM and check if Enhanced mode is available

More info can be found at https://docs.microsoft.com/en-us/windows-server/virtualization/hyper-v/learn-more/use-local-resources-on-hyper-v-virtual-machine-with-vmconnect

Till next time See ya

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.