7

Just installed Ubuntu server 22.04 and as I needed a DE, followed some tutorials where most of them suggested that I can install gnome (or ubuntu-desktop) using the tasksel command.

After doing so I encountered two problems: the mouse pointer on desktop is showing as a solid gray square ⬛ and the hotspot is at upper left corner. However when I run any gui app the pointer is drawn perfectly fine.

How can I fix this issues?

6
  • If you "need a DE" why didn't you install the desktop version instead? Commented May 31, 2022 at 17:22
  • 1
    @ChanganAuto for learning purposes
    – user174174
    Commented May 31, 2022 at 21:25
  • 1
    "Ubuntu server" lacks the GUI components and services that your DE depends on. Start over, and install "Ubuntu desktop", since you want to use your computer as a desktop.Telling us which remote procedure (RP) you "followed" doesn't help us help you for N reasons: 1) It's remote. Will the link exist tomorrow? 2) Reading the RP doesn't tell us how accurately you "followed" it. Did you suffer typos or missed lines? We have. 3) Reading the RP omits the error messages you got on your system. These error messages (and the commands that caused them) are key elements in any diagnosis.
    – waltinator
    Commented Jun 1, 2022 at 1:28
  • @waltinator if I wanted to install the desktop version, obviously wouldn't proceeded to download the server in the first place. I'm sure it's possible to add gui to the server and looking for some help regarding that. About the error messages I know I need to provide those but didn't encounter any.
    – user174174
    Commented Jun 1, 2022 at 2:52
  • I actually have this issue on desktop. :-) Commented Aug 30, 2022 at 5:39

4 Answers 4

8

I faced the same problem on Ubuntu 24.04 beta, on GNOME / Ubuntu desktops, using my preferred cursor theme DMZ-White. When the mouse is over the top bar or the dock/launcher (whatever it's called), the mouse pointer is a light gray (almost white) square.

It seems to me that the icon theme is missing the default file. For me this solution worked:

Check which cursor theme you're using. Start gnome-tweaks and go to Appearance -> Styles -> Cursor.

In a terminal, navigate to its directory under /usr/share/icons and then the cursors subdirectory underneath, e.g.

cd /usr/share/icons/DMZ-White/cursors/

(The cursor theme's name may not directly map to the filesystem directory name, use common sense to find it.)

Then create the missing symbolic link (or copy the file):

sudo ln -s left_ptr default

Then switch to a different cursor theme in gnome-tweaks and back to this one, for the change to take effect. Or log out and log back in.

5
  • Fixed my issue. Hopefully the bug is fixed upstream before full release of 24.04. Commented Apr 15 at 20:20
  • @QwertyChouskie I'm glad it worked for you! Unfortunately I'm afraid no one's working on it in the Ubuntu team. What I showed here may not even be the proper fix, I don't know. We should bring this problem to their attention.
    – egmont
    Commented Apr 15 at 20:42
  • 2
    this works. even in 24.04
    – xkeshav
    Commented Apr 26 at 9:39
  • @egmont I just filed a Launchpad bug report: bugs.launchpad.net/ubuntu/+source/dmz-cursor-theme/+bug/2065947 Commented May 17 at 0:40
  • @QwertyChouskie Thanks a lot!
    – egmont
    Commented May 17 at 9:26
2

If inside the VirtualBox VM, and with the latest kernel 6.5.*, it is necessary to install the newer compiler:

sudo apt install gcc-12

After that, it is necessary to install the latest Guest Additions.

0

I have found that changing the cursor theme works: How do I change the cursor and its size?

apt install oxygen-cursor-theme
update-alternatives --config x-cursor-theme
0

What solved it for me was going into the Menu -> "Tweaks" -> "Appareance" and set Cursor to one of the options in the blank dropdown. In my case, "DMZ Black".

Note that this requires the ubuntu-desktop install using tasksel. The minimal one doesn't come with "Tweaks" afaik.

1
  • For Ubuntu Server it is best to install whole ubuntu-desktop package.
    – pbies
    Commented Apr 2 at 3:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .