5

I have installed Ubuntu Studio, Version 22.04 LTS. I have also a NTFS partition at the same disk, which contains previously installed Windows OS. Ubuntu Studio seems to automatically mount the NTFS partition at every computer startup (unlike normal Ubuntu).

Where can I disable automounting of the NTFS partition at every computer startup?

I would expect the automount to take place in /etc/fstab, but it is not there (I replaced parts of the UUIDs with x).

cat /etc/fstab:

UUID=664A-xxxx                            /boot/efi      vfat    umask=0077 0 2
UUID=6b1fe799-xxxx-xxxx-xxxx-xxxxxxxxxxxx /              ext4    defaults,discard 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=6af10a10-xxxx-xxxx-xxxx-xxxxxxxxxxxx none           swap    sw              0       0

The automounted partition is /dev/sda3 and it gets mounted under /media/user/WIN10. There is also another NTFS partition /dev/sda4 at the disk (500MB), but it has got flags hidden,diag and it does not get automounted (just for explanation).

My blkid output:

/dev/sda1: LABEL_FATBOOT="EFIBOOT" LABEL="EFIBOOT" UUID="664A-xxxx" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="98cb88bd-xxxx-xxxx-xxxx-xxxxxxxxxxxx"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="c96cdcf0-xxxx-xxxx-xxxx-xxxxxxxxxxxx"
/dev/sda3: LABEL="WIN10" BLOCK_SIZE="512" UUID="F60xxxxxxxxxxxxx" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="84569d75-xxxx-xxxx-xxxx-xxxxxxxxxxxx"
/dev/sda4: BLOCK_SIZE="512" UUID="981xxxxxxxxxxxxx" TYPE="ntfs" PARTUUID="5c62d1c5-xxxx-xxxx-xxxx-xxxxxxxxxxxx"
/dev/sda5: LABEL="UBUNTU" UUID="6b1fe799-xxxx-xxxx-xxxx-xxxxxxxxxxxx" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="7ed7d9b3-xxxx-xxxx-xxxx-xxxxxxxxxxxx"
/dev/sda6: UUID="6af10a10-xxxx-xxxx-xxxx-xxxxxxxxxxxx" TYPE="swap" PARTUUID="d74bac71-xxxx-xxxx-xxxx-xxxxxxxxxxxx"

mount | grep sda output:

/dev/sda5 on / type ext4 (rw,relatime,discard)
/dev/sda1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/sda3 on /media/user/WIN10 type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

dmesg | grep -i mount:

[    0.122566] Mount-cache hash table entries: 32768 (order: 6, 262144 bytes, linear)
[    0.122566] Mountpoint-cache hash table entries: 32768 (order: 6, 262144 bytes, linear)
[    5.411235] EXT4-fs (sda5): mounted filesystem with ordered data mode. Opts: (null). Quota mode: none.
[    5.755437] systemd[1]: Set up automount Arbitrary Executable File Formats File System Automount Point.
[    5.757201] systemd[1]: Mounting Huge Pages File System...
[    5.757925] systemd[1]: Mounting POSIX Message Queue File System...
[    5.758788] systemd[1]: Mounting Kernel Debug File System...
[    5.759805] systemd[1]: Mounting Kernel Trace File System...
[    5.773131] systemd[1]: Starting Remount Root and Kernel File Systems...
[    5.779286] systemd[1]: Mounted Huge Pages File System.
[    5.779562] systemd[1]: Mounted POSIX Message Queue File System.
[    5.780677] systemd[1]: Mounted Kernel Debug File System.
[    5.780872] systemd[1]: Mounted Kernel Trace File System.
[    5.782590] EXT4-fs (sda5): re-mounted. Opts: discard. Quota mode: none.
[    5.786367] systemd[1]: Finished Remount Root and Kernel File Systems.
[    5.787998] systemd[1]: Mounting FUSE Control File System...
[    5.789074] systemd[1]: Mounting Kernel Configuration File System...
[    5.799944] systemd[1]: Mounted FUSE Control File System.
[    5.800204] systemd[1]: Mounted Kernel Configuration File System.

dmesg | grep sda:

[    1.809792] sd 1:0:0:0: [sda] 976773168 512-byte logical blocks: (500 GB/466 GiB)
[    1.809809] sd 1:0:0:0: [sda] Write Protect is off
[    1.809822] sd 1:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    1.809884] sd 1:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    1.818988]  sda: sda1 sda2 sda3 sda4 sda5 sda6 sda7
[    1.830314] sd 1:0:0:0: [sda] supports TCG Opal
[    1.830318] sd 1:0:0:0: [sda] Attached SCSI disk
[    5.411235] EXT4-fs (sda5): mounted filesystem with ordered data mode. Opts: (null). Quota mode: none.
[    5.782590] EXT4-fs (sda5): re-mounted. Opts: discard. Quota mode: none.
[    6.872724] Adding 4002812k swap on /dev/sda6.  Priority:-2 extents:1 across:4002812k SSFS

dmesg | grep -i ntfs:

[   62.029982] ntfs3: Max link count 4000
[   62.029991] ntfs3: Enabled Linux POSIX ACLs support
[   62.029992] ntfs3: Read-only LZX/Xpress compression included
[   62.033266] ntfs3: Unknown parameter 'windows_names'
2
  • 2
    Take a look at System Settings > Removable Storage > Removable Devices, anything helpful there?
    – mook765
    May 30, 2022 at 21:09
  • Yes, this it it, thank you! Do you know how can I achieve this from command line or by editing some configuration files? I tried to grep all files in /etc/ for "mount" and "ntfs" and no clue.
    – ethcz
    May 31, 2022 at 15:48

2 Answers 2

2

Automounting can be configured in System Settings > Removable Storage > Removable Devices:

enter image description here

The config file is ~/.config/kded_device_automounterrc, you could edit this file manually, but this changes only the file but does not apply the new settings.

1
  • You are right, editing the file does not apply the settings. But stil this is the solution that works, thank you.
    – ethcz
    May 31, 2022 at 20:02
0

You can add the partition to /etc/fstab with the noauto option. So the fstab entry should look like:

UUID=<UUID of Windows partition here>        /media/user/WIN10       ntfs      noauto

Replace <UUID of Windows partition here> with the necessary value - you can find the UUID by running lsblk to determine the device name that corresponds to your Windows partition, then run blkid to find the UUID associated with that device name. (Note that you want the UUID, not the PART_UUID.)

2
  • It seems promising, but unfortunately it doesn't work at all. Even if I use 'UUID=F60xxxxxxxxxxxxx' instead of '/dev/sda3'.
    – ethcz
    May 31, 2022 at 15:43
  • Thanks for editing the answer, but as I have already commented - it does not work. I am using UUID, not the PART_UUID, I know about it.
    – ethcz
    Jun 1, 2022 at 22:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .