9

New, and updated, installation of Ubuntu 22.04 on a Asus K52J Pc (2010). The gnome-control-center (aka Gnome system Settings) is not opening.

I can see the icon on the left bar, and if I right-click on it, under All Windows, I can also see the preview of the opened window, but it doesn't show.

Trying to do sudo gnome-control-center gives

(gnome-control-center:19545): dconf-WARNING **: 15:18:02.653: failed to commit changes to dconf: Failed to execute child process “dbus-launch” (No such file or directory)
Error creating rfkill proxy: (null)
Segmentation fault

Any solution?


Edit

I tried to

sudo apt purge gnome-control-center
sudo apt install gnome-control-center

with no result. Also tried to

sudo apt install dbus-x11

with no result.


Edit

Found out that also Libre Office is not opening... maybe that's related.

4 Answers 4

3

I had the same issue and the "purge/install gnome-control-center" approach worked like a charm. Problem solved!

1
  • purging and reinstalling didn't work for me. It was reinstalled again with Display Mode set as 2 Join Displays.
    – the_eraser
    Feb 10, 2023 at 11:31
2

I had the same issue - after upgrading to 22.04, my gnome-control-center was not there.

If I tried 'apt install gnome-control-center', it appeared, I had a broken package, apparently installed without apt, and had to do (in my case, it was remmina and libfreerdp, 'apt remove remmina libfreerdp-2.2', then 'apt autoremove', to clean up.

I could get remmina back with 'apt install remmina', which fetched an apt supported application.

Now, I was able to do 'apt install gnome-control-center', and got the settings back (phew, luckily, the gnome settings is a nice thing to have available). :)

1

issue: On Ubuntu 22.04, Settings was not showing up

problem: Ubuntu came set w/ Display Mode set w/ 2 Join Displays (even though just 1 laptop built-in display has always been physically available). Settings was opening on the other display (and clicking on preview on left pane is apparently no meant to switching display).

solution: Shift+Super+Left or Shift+Super+Right move window one monitor to left or right making Settings showing up. Also Super+Tab (switching application) or Super+Up (maximizing window) and SUper+Down (minimizing window) can help. After managing to show the Settings, go to Display and in Display Mode set Single Display.

1

An alternative solution that may be applicable to some using wine32 is switching from libgd3:i386 to 64 bit version.

I specifically ran:

sudo apt install gnome-control-center colord libgd3

To fix it in my situation.

1
  • Works fro me, too. Thanks!
    – dsha256
    Feb 21, 2023 at 21:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .