9

I have just installed Ubuntu 22.04 on an AMD machine running a threadRipper 3960X with a GeForce RTX 2060.

The system is dual boot and upon selecting Ubuntu on grub I get the following message:

enter image description here

Is this a reason for concern? If so, what can I do to solve it?

21
  • Check your BIOS version with sudo dmidecode -s bios-version, and then go to the manufacturer's web site and check for a newer BIOS.
    – heynnema
    May 30, 2022 at 13:55
  • Hi, thanks for the input. I updated my bios from version 2.6 to 2.7 but still get pretty much the same error. i.ibb.co/j3t48Xk/Screenshot-2022-05-30-160505.png May 30, 2022 at 15:07
  • Is this a desktop computer? What brand motherboard? Which Nvidia, and what version driver?
    – heynnema
    May 30, 2022 at 15:09
  • It is a desktop computer. Motherboard: MSI TRX40 PRO WIFI, GeForce RTX 2060 and nvidia-driver-510 May 30, 2022 at 15:12
  • Besides the Nvidia, do you have any other cards installed?
    – heynnema
    May 30, 2022 at 15:13

3 Answers 3

5
+100

You can get rid of those ACPI Error messages by

  1. Open /etc/default/grub in an editor with root access. In your case I believe Ubuntu uses gedit as it's text editor:

     sudo gedit /etc/default/grub
    
  2. The line with GRUB_CMDLINE_LINUX_DEFAULT, add the loglevel=3 part. The original looks like

     GRUB_CMDLINE_LINUX_DEFAULT='quiet splash'
    

Change it to this:

GRUB_CMDLINE_LINUX_DEFAULT='quiet splash loglevel=3'

Then save the changes and close it, now open a terminal and run:

sudo update-grub

Reboot and see the results

3
  • This actually worked! Woo hoo, confirmed on 2 different machines. These messages started with a kernel update and have been bugging me. You, human being of exceptional merit, are getting a bounty when the system allows. Aug 24, 2022 at 21:16
  • thanks sir it is working
    – Shamsail
    Sep 27, 2022 at 8:22
  • It worked to hide the error message. Jan 22 at 10:53
0

From the comments...

You have a hardware problem with the i2c circuitry on the MSI TRX40 PRO WIFI motherboard (BIOS 2.7), or a hardware problem with the GeForce RTX 2060 video card.

Contact MSI Support at https://www.msi.com/support, and Nvidia support at https://www.nvidia.com/en-us/support/consumer/, for further assistance.

Or, if the computer is under warranty, contact the warranty provider.

Update #1:

Ran a Windows Memory Diagnostic and it reported a memory problem.

Update #2:

The computer went to the seller for a warranty technical evaluation.

0

The ACPI tables in your BIOS are incorrect, and Linux shows error messages during interpretation as it detects the problem.

The tables contain a list of devices in the system, typically those that cannot be found by another method, such as those connected to an I2C bus on the mainboard, as there is no reliable mechanism for scanning an I2C bus.

In your case, there are some duplicate entries, so the second instance is ignored. This probably happened because an older version of the BIOS shipped these entries as part of a supplemental table, and a later version included them into the main table, but the supplemental table was not removed.

These errors should be harmless and can be ignored as long as the system works fine otherwise.

1
  • 1
    These errors started showing up after a kernel update. No UEFI update has been done on these machines for years. Aug 25, 2022 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.