7

I recently upgraded to 22.04. Wifi works a charm, ethernet does not.

Here is the result of network-test

INFO: This system has exactly one default route
INFO: Host localhost answers to ICMP pings
INFO: Loopback interface is working properly
INFO: The eno2 interface is up
WARN: The eno2 interface does not have an IP address assigned
WARN: The eno2 interface has not received any packets.
INFO: The wlo1 interface is up
INFO: The wlo1 interface has IP address 192.168.1.87 assigned
INFO: The wlo1 interface has tx and rx packets.
INFO: The router 192.168.1.1 is reachable
INFO: This system is configured to use nameserver 127.0.0.53
INFO: Host 127.0.0.53 answers to ICMP pings
INFO: Dns server 127.0.0.53 resolved correctly www.debian.org
INFO: The nameserver configured for this system works properly
INFO: System can reach Internet host www.debian.org
INFO: System can access web server at Internet host www.debian.org (port 80)

Here is the result of lshw -c network

 *-network:1
       description: Ethernet interface
       product: Ethernet Connection (7) I219-V
       vendor: Intel Corporation
       physical id: 1f.6
       bus info: pci@0000:00:1f.6
       logical name: eno2
       version: 10
       serial: 3c:7c:3f:d8:99:1d
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=5.15.0-33-generic duplex=full firmware=0.5-4 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:128 memory:91200000-9121ffff

And here is the result of ifconfig -a

eno2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::ca90:e249:8955:baf4  prefixlen 64  scopeid 0x20<link>
        ether 3c:7c:3f:d8:99:1d  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1133  bytes 190976 (190.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  memory 0x91200000-91220000  

Clearly, the wired connection gets no IP assigned (I tried assigning one manually, but it still receives no packets). However, I guess this would usually be expected to work "out of the box". Any hints as to what information may help/what I should try to fix this much appreciated.

For completeness's sake:

lshw -short

H/W path         Device          Class          Description
===========================================================
                                 system         System Product Name (ASUS_MB_CNL)
/0                               bus            TUF Z390-PLUS GAMING (WI-FI)
/0/0                             memory         64KiB BIOS
/0/43                            memory         64GiB System Memory
/0/43/0                          memory         Project-Id-Version: lshwReport-Msgid-Bugs-To: FULL NAME <EMAIL@ADDRESS>PO-Revision-Date: 2012-02-05 00:26+0000Last-Translator: Andi Chandler <Unknown>Language-Team
/0/43/1                          memory         32GiB DIMM DDR4 Synchronous 3200 MHz (0.3 ns)
/0/43/2                          memory         Project-Id-Version: lshwReport-Msgid-Bugs-To: FULL NAME <EMAIL@ADDRESS>PO-Revision-Date: 2012-02-05 00:26+0000Last-Translator: Andi Chandler <Unknown>Language-Team
/0/43/3                          memory         32GiB DIMM DDR4 Synchronous 3200 MHz (0.3 ns)
/0/4e                            memory         384KiB L1 cache
/0/4f                            memory         1536KiB L2 cache
/0/50                            memory         9MiB L3 cache
/0/51                            processor      Intel(R) Core(TM) i5-9600K CPU @ 3.70GHz
/0/100                           bridge         8th Gen Core Processor Host Bridge/DRAM Registers
/0/100/1                         bridge         6th-10th Gen Core Processor PCIe Controller (x16)
/0/100/1/0                       display        TU106 [GeForce RTX 2060 Rev. A]
/0/100/1/0.1     card1           multimedia     TU106 High Definition Audio Controller
/0/100/1/0.1/0   input19         input          HDA NVidia HDMI/DP,pcm=3
/0/100/1/0.1/1   input20         input          HDA NVidia HDMI/DP,pcm=7
/0/100/1/0.1/2   input21         input          HDA NVidia HDMI/DP,pcm=8
/0/100/1/0.1/3   input22         input          HDA NVidia HDMI/DP,pcm=9
/0/100/1/0.1/4   input23         input          HDA NVidia HDMI/DP,pcm=10
/0/100/1/0.1/5   input24         input          HDA NVidia HDMI/DP,pcm=11
/0/100/1/0.1/6   input25         input          HDA NVidia HDMI/DP,pcm=12
/0/100/1/0.2                     bus            TU106 USB 3.1 Host Controller
/0/100/1/0.2/0   usb3            bus            xHCI Host Controller
/0/100/1/0.2/1   usb4            bus            xHCI Host Controller
/0/100/1/0.3                     bus            TU106 USB Type-C UCSI Controller
/0/100/14                        bus            Cannon Lake PCH USB 3.1 xHCI Host Controller
/0/100/14/0      usb1            bus            xHCI Host Controller
/0/100/14/0/5                    generic        BCM20702A0
/0/100/14/0/6                    input          USB Receiver
/0/100/14/0/6/0  input16         input          Logitech M310
/0/100/14/0/6/1  input17         input          Logitech K520
/0/100/14/0/e                    communication  Bluetooth 9460/9560 Jefferson Peak (JfP)
/0/100/14/1      usb2            bus            xHCI Host Controller
/0/100/14.2                      memory         RAM memory
/0/100/14.3      wlo1            network        Cannon Lake PCH CNVi WiFi
/0/100/16                        communication  Cannon Lake PCH HECI Controller
/0/100/17        scsi2           storage        Cannon Lake PCH SATA AHCI Controller
/0/100/17/0      /dev/sda        disk           2TB WDC WD20EARX-00P
/0/100/17/0/1    /dev/sda1       volume         1846GiB EXT4 volume
/0/100/17/0/2    /dev/sda2       volume         16GiB Linux swap volume
/0/100/17/1      /dev/sdb        disk           64GB ADATA SP900
/0/100/17/1/1    /dev/sdb1       volume         19GiB Extended partition
/0/100/17/1/1/5  /dev/sdb5       volume         19GiB EXT4 volume
/0/100/17/1/2    /dev/sdb2       volume         39GiB EXT4 volume
/0/100/1b                        bridge         Cannon Lake PCH PCI Express Root Port #17
/0/100/1b/0      /dev/nvme0      storage        Samsung SSD 970 EVO Plus 500GB
/0/100/1b/0/0    hwmon1          disk           NVMe disk
/0/100/1b/0/2    /dev/ng0n1      disk           NVMe disk
/0/100/1b/0/1    /dev/nvme0n1    disk           500GB NVMe disk
/0/100/1b/0/1/1  /dev/nvme0n1p1  volume         528MiB Windows NTFS volume
/0/100/1b/0/1/2  /dev/nvme0n1p2  volume         98MiB Windows FAT volume
/0/100/1b/0/1/3  /dev/nvme0n1p3  volume         15MiB reserved partition
/0/100/1b/0/1/4  /dev/nvme0n1p4  volume         139GiB Windows NTFS volume
/0/100/1b/0/1/5  /dev/nvme0n1p5  volume         325GiB EXT4 volume
/0/100/1c                        bridge         Cannon Lake PCH PCI Express Root Port #1
/0/100/1d                        bridge         Cannon Lake PCH PCI Express Root Port #9
/0/100/1f                        bridge         Z390 Chipset LPC/eSPI Controller
/0/100/1f/0                      system         PnP device PNP0c02
/0/100/1f/1                      system         PnP device PNP0c02
/0/100/1f/2                      system         PnP device PNP0c02
/0/100/1f/3                      generic        PnP device INT3f0d
/0/100/1f/4                      system         PnP device PNP0c02
/0/100/1f/5                      system         PnP device PNP0c02
/0/100/1f/6                      system         PnP device PNP0c02
/0/100/1f/7                      system         PnP device PNP0c02
/0/100/1f.3      card0           multimedia     Cannon Lake PCH cAVS
/0/100/1f.3/0    input26         input          HDA Intel PCH Front Mic
/0/100/1f.3/1    input27         input          HDA Intel PCH Rear Mic
/0/100/1f.3/2    input28         input          HDA Intel PCH Line
/0/100/1f.3/3    input29         input          HDA Intel PCH Line Out
/0/100/1f.3/4    input30         input          HDA Intel PCH Front Headphone
/0/100/1f.4                      bus            Cannon Lake PCH SMBus Controller
/0/100/1f.5                      bus            Cannon Lake PCH SPI Controller
/0/100/1f.6      eno2            network        Ethernet Connection (7) I219-V
/1                               power          To Be Filled By O.E.M.
/2               /dev/fb0        display        EFI VGA
/3               input0          input          Sleep Button
/4               input1          input          Power Button
/5               input18         input          Eee PC WMI hotkeys
/6               input2          input          Power Button
3
  • Hey i'm facing the same issue, my adapter is: "RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller". Did you manage to fix it. Commented Jun 22, 2022 at 8:12
  • I have the same issue as well
    – zpontikas
    Commented Oct 21, 2022 at 20:26
  • I had a similar problem (updated Kubuntu, restarted, and ethernet didn't work while WiFi did and while #2 it worked fine when I dualbooted into Windows10). It was caused by the "generally safe" (!!) apt autoremove. I pulled the removed packages by grep remove /var/log/dpkg.log and reinstalled most of them, save for linux-headers* and such. Rebooted the system and all was good. #Kubuntu2204 #DontTrustAutoremove
    – edison23
    Commented Aug 6, 2023 at 19:44

1 Answer 1

1

I am happy to report that I got this to work. For me the package netplan.io was missing. This was causing the yaml /etc/netplan/01-network-manager-all.yaml to not be applied. If this yaml file is missing for you have a look at this answer for what its contents should be.

2
  • why was it missing and how did you get to this state? i did a simple ubuntu-driver autoinstall and it bricked me
    – safetyduck
    Commented Jul 12, 2022 at 15:28
  • I am not sure why the netplan.io package was missing originally in my case. It must have been removed along with other packages. Commented Aug 16, 2022 at 14:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .