I've upgraded my Kubuntu 21.10 VM today, to 22.04 LTS. The install went fine, and everythin was upgraded. After it reboot, however, I'm simply met with the following message:

SMBus base address uninitialized - upgrade BIOS or use force_addr=0xaddr

The KDE environment never boots, even if I leave it awhile.

I can switch to a different terminal, using Ctrl+Alt+F2, for example, and log into the terminal, but I cannot get the GUI to load.

I've seen this question, SMBus/ BIOS error while booting Ubuntu in VirtualBox, which has the same error but in VirtualBox, and tried blacklisting both i2c_piix4 and intel_rapl; same result. Checking lsmod afterwards, it was still loaded even though blacklisted. I also tried putting the black list in the file /etc/modprobe.d/no_i2c_piix4.conf; same result and still loaded.

Does anyone have any ideas why this is happening, and how to fix?

  • Have you made any progress on that?
    – Akito
    Jul 26, 2022 at 21:04

1 Answer 1


It turned out the problem here was that the VM was a Gen 1 VM, and 22.04 needs a Gen 2 VM (or at least, I could not get it to work as a Gen 1 VM).

Upgrading an existing VM from a Gen 1 to a Gen 2 isn't possible. What you can do, however, is delete the existing VM (make sure you don't delete it's vhd files), and then create a new Gen 2 VM and attack the old vhd files to it. This should "upgrade" the system to a Gen 2; though apparently it is a 1 way process.

I also noted, through research, that you should disable Secure Boot on the VM; I had this off any way, but if you do have it enabled and are having difficulty, then I would suggest trying to disable it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.