6

After trying to switch from Intel driver to the Nvidia graphics driver on my notebook computer, using Software Updates option from the gnome-control-center, it now boots only to command prompt with no attempt to display a graphical login screen. I tried all the "terminals", using Ctrl+Alt+F1, F2, and so on, but none has the GUI login prompt.

I tried some answers in AskUbuntu, like reinstalling ubuntu-desktop, using the tasksel command to (re)install desktop, removing and reinstalling NVIDIA drivers, trying to switch back to Intel driver, using systemctl set-default graphical.target, but none of them helped.

I have done similar graphics driver switches (Intel ⟷ Nvidia) in the previous versions of Ubuntu for various reasons and never had this problem. My system was upgraded to 22.04 from 21.10 in the end of April. I am using this very system since 18.10 and upgraded every six months with no Ubuntu re-installation so far. The system is fully updated.

The startx command opens a tiny white terminal at the top left corner of the screen. I can run the command gnome-shell to bring up GNOME, but it is very slow and some GUI tools like gnome-terminal or gnome-control-center just crash.

I also noticed that the directory /etc/X11 and its sub-directories of are all empty now. It may be a problem with Xorg.

1 Answer 1

6

The problem was fixed after purging and reinstalling gdm3:

$ sudo apt purge gdm3
$ sudo apt install gdm3 ubuntu-desktop

After the above, I noticed that a file named /etc/X11/default-display-manager appeared and it has the following contents:

/usr/sbin/gdm3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.