11

Hitting Super+Space to switch keyboard layout seriously disrupts my workflow. Every time I switch the layout, text fields get unfocused and I have to select the field again to start typing. And it's just unusable in fullscreen mode, because the fullscreen window gets collapsed.

I suppose, it's some kind of bug, related to the keyboard layout-switching overlay (normally it appears after you hold Super+Space for a second). It seems like it appears event if I press Super+Space very briefly and throws focus off the active windows.

What can I do about this? Isthere some config to disable this overlay altogether?

2
  • Welcome to AskUbuntu, perhaps change the shortcut key to Control+Space (or something you like) will only do the layout change. Now Super key bound to a window manipulation, imho. May 27, 2022 at 9:46
  • 1
    Well, this is a default combination in many systems. Anyway, rebinding doesn't help. May 27, 2022 at 13:37

4 Answers 4

12

Using this extension solved my problem: Quick Lang Switch

3
  • 2
    This is the best option for solving this issue and also removes the quite annoying delay of the language switcher! Feb 22, 2023 at 13:15
  • 1
    OMG it really works. Faced the issue of unfocusing a whole window on input source change and didn't find anything else expect ur answer. Quick and productive solution
    – Dominux
    Mar 3, 2023 at 15:34
  • 1
    Great! I expected there to be some Gnome extension for that
    – m_ocean
    Mar 27, 2023 at 13:03
2

The only way I found is to change a setting in Tweaks: In the Windows section change the Window Focus to Focus on Hover or Secondary-Click.

It may be tricky at first, but you get used to it at no time.

2

I found a workaround but not a solution, unfortunately. As @Viktor mentioned, you can select your option in Tweaks (but excluding Win key in my experience), for example Alt+Shift. Also you need to disable shortcut Win+Space in System Settings → KeyboardKeyboard ShortcutsTyping.

0

I use GNOME Tweak Tool (GNOME Tweaks in the Ubuntu Software now) as a workaround:

  • Keyboard & Mouse in the left menu.
  • Additional Layout Options button in the right part of the window.
  • Switching to another layout.
  • Select the combination you want. It will not show the overlay.

Gnome Tweak Tool

And in general I'm waiting for a solution too. It's very annoying and completely unusable with individual input source for each window. In this case language is switched only for the language switch overlay.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .