14

Just upgraded to 22.04 from 21.10. Flameshot not working. I click on the Flameshot icon and nothing happens. How to fix this?

5
  • Maybe, something in the system logs can help you find the root cause for the issue. Please, have a look at /var/log/syslog, and search it for "flameshot"
    – RobertG
    Commented Jun 10, 2022 at 15:24
  • Could it be that you do see a tray icon appear? Because that is what happens when I press the icon from the launcher menu. Try to run flameshot gui from a terminal and see what happens. Also see: github.com/flameshot-org/flameshot#usage
    – Sebastian
    Commented Jun 10, 2022 at 20:06
  • The workaround is to use Ubuntu on Xorg as per this reference: askubuntu.com/questions/1344236/…
    – gnsr
    Commented Nov 22, 2022 at 15:34
  • Are you using X11 or Wayland? Could be a Wayland issue. Commented Feb 26, 2023 at 11:46
  • @MartinZeltin It's been working and I'm using Wayland. I think an update fixed it about 8 months ago.
    – Advait
    Commented Feb 27, 2023 at 12:41

8 Answers 8

8

Firstly do not install flameshot from snapstore, install it using apt.

  • Go to /etc/gdm3/custom.conf
  • Remove the comment on #WaylandEnable=false

Your custom.conf file should be like this:

# GDM configuration storage
#
# See /usr/share/gdm/gdm.schemas for a list of available options.

[daemon]
# Uncomment the line below to force the login screen to use Xorg
WaylandEnable=false

# Enabling automatic login
#  AutomaticLoginEnable = true
#  AutomaticLogin = user1

# Enabling timed login
#  TimedLoginEnable = true
#  TimedLogin = user1
#  TimedLoginDelay = 10

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
# More verbose logs
# Additionally lets the X server dump core if it crashes
#Enable=true

Save custom.conf file and restart your machine

1
  • 1
    This seems also solve the issue of parcellite.
    – Eric
    Commented Dec 22, 2023 at 11:03
5

Not sure if this is the issue from the OP but I came here having the same symptoms and this was the solution:

When you install Flameshot from the software center you get only one icon in Gnome. If you click this button nothing happens. Except for a tray icon that probably goes unnoticed to most users (like me).

From the Flameshot documentation on GitHub:

[...] will launch a running instance of the program in background without taking actions [...]

To actually take a screenshot you would have to run flameshot gui but there is no icon for that.

Take screenshot to test

To test the functionality you have two options:

  1. Right click the launcher icon, in the context menu you should have the option to 'Take screenshot'
  2. Run flameshot gui from a terminal or by pressing Alt+F2 and copy paste/type the command there.

You should get a security prompt by Gnome, asking if you are OK to share the entire screen(shot) to the application (Flameshot). You click 'share' and now Flameshot opens as you know it. (At the time of writing you cannot disable this security step)

Make a keyboard shortcut

Now to get a more convenient way to start Flameshot you can add a keyboard shortcut to the command flameshot gui. Explained here on the GitHub page of Flameshot. For example you can bind this command to the PrtScn button.

Customise the default launcher

Alternatively you could edit the default Flameshot launcher to take the screenshot immediately when clicking the icon.

First copy the *.desktop file to your home directory so it will persist even when the system udpates or whatever:

cp /usr/share/applications/org.flameshot.Flameshot.desktop ~/.local/share/applications

Then edit the copy somehow:

gedit ~/.local/share/applications/org.flameshot.Flameshot.desktop

Find the (first) line that says:

Exec=/usr/bin/flameshot gui --delay 500

And append it like this:

Exec=/usr/bin/flameshot gui --delay 500
3
  • 1
    OP here. Using Ubuntu 22.04. Flameshot is installed. Here's what happens: * I go to the Gnome "search" screen, type in "flame", the large Flameshot icon appears, I click on it and a very small Flameshot icon appears in my dock, I click on the tiny Flameshot icon and a menu appears, one of the menu items is "Take a Screenshot"", I click on this and nothing happens. How to fix this? Thanks. PS: I do a Ubuntu software update everyday. PS: Flameshot worked fine in 21.10, I didn't have to do anything special for it to work great.
    – Advait
    Commented Jun 12, 2022 at 3:57
  • What happens when you run flameshot gui from the command line?
    – Sebastian
    Commented Jun 13, 2022 at 10:28
  • Here's what hppens: advait@advait-Bravo-15-A4DDR:~$ flameshot gui Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway. . Then nothing more happens and I have to hit ctrl-c to kill the process. I'm using Wayland. I'll wait til the Flameshot bugs are fixed and use Gnome Screenshot in the meantime. I'm not willing to run X11.
    – Advait
    Commented Jun 14, 2022 at 11:08
2

OP here. Issue Resolved. It's working. The solution is I take a screenshot with Flameshot and then a dialog box appears with the option to share the screenshot with Flameshot. I do this and then I can edit the screenshot using the very nice Flameshot tools and UI. Kind of a weird and convoluted process, but it works in Wayland. I found this solution months ago but only today I got a reminder email about this issue.

1

Try switching to x.org at login.

At login, as you clock in the password field, a small gear icon appears at the bottom right of the login screen. Click it and select xorg.

Before doing that, it is worth checking if you have xorg installed entering dpkg --list | grep xorg in terminal

If you don't have it, you can install it with sudo apt install xorg openbox

Logout, login again (selecting xorg in the login screen) and it should work.

(At least it did for me.)

1

Ubuntu 23.10 Solve like this Screenshot

i modify launcher command in the startup programs like this

sh -c -- "flameshot"

That's all folks!

1
  • Very good solution ! avoids all wayland and non default stuff ... Also tested and working for ubuntu 24.04 Commented May 13 at 18:49
0

I did the update this week. There were initial hickups.

  • As I usually do, I changed the keyboard binding for "Print" to call flameshot gui instead of the default screenshot tool (I disabled that hotkey before I added a custom binding for Flameshot).
  • It worked, but I would have to take a screenshot first, then "Share" it with Flameshot, and only then could I use Flameshot like before, like normal.
  • Although it was a different issue, maybe, it disappeared for me, yesterday or so. With a recent update, I presume. Now I just press print, then Flameshot launches directly, like it used to in the past.

Could you run all updates, then re-check if it's working for you then?

Also, could you launch Flameshot once by hand, then check your settings? E.g. "launch at startup" must be enabled, or it won't react to hotkeys, if I remember correctly.

If you give more details, I'll gladly provide more detailed information (like, ironically, screenshots).

4
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Jun 3, 2022 at 21:44
  • OP here. I just did all the updates and re-installed Flameshot. Still not working. I'll check again after some time and hope that the devs are working on this.
    – Advait
    Commented Jun 8, 2022 at 4:07
  • On my Ubuntu 22.04 it opens, but the clipboard copying doesn't work at all for me Commented Jun 9, 2022 at 22:44
  • Sorry then, I don't think I have had the same kind of problem then, and won't be able to help. And, as the bot pointed out, I should not have answered then. :(
    – RobertG
    Commented Jun 10, 2022 at 15:22
0

Flameshot v12.1.0

Ubuntu 24.04

This works for me:

  • open the flameshot
  • click the flameshot icon on top right bar of ubuntu. do NOT click "Take Screenshot" yet, but click "Configuration" instead
  • with the flameshot configuration window opened, click the flameshot icon again on top right bar, this time click the "Take Screenshot", voila!

Take the screenshot as you normally do and as many times you'd like, the flameshot is now working as normal.

If you restart your computer, then you have to redo the above steps.

Good luck!

New contributor
Star Space is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

I fixed this problem with this steps:

  • sudo vim /etc/gdm3/custom.conf
  • uncomment WaylandEnable=false
  • sudo systemctl restart gdm3 (maybe reboot)
  • if the screen turns the wrong yellow color:
    • Settings -> Color
    • Remove color profile from the monitor and add Colorspace:sRGB
  • Set shortcut for screenshot:
    • Settings -> Keyboard -> Keyboard shortcuts
    • Select Custom shortcuts
    • Add new one:
      • Name: Flameshot
      • Command: flameshot gui
      • Shortcut: any (F7 for example)

Profit: now flameshot works and screenshot quick with shortcut

New contributor
Arty Gvozdenkov is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .