0

When using nvidia-smi

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

when using nvidia-settings

ERROR: NVIDIA driver is not loaded ERROR: Unable to load info from any available system

relevant info:

  • model: Dell xps 15 9560
  • cpu: i7-7700HQ
  • gpu: Geforce GTX 1050 mobile
  • ubuntu version: 20.04
  • kernel: 5.4.196
  • driver: 470

This setup worked previously but i think a recent update to either the driver or the kernel broke it.

I already tried

  • Purging and uninstalling all of the nvidia drivers several times and installing them in several different ways.
  • setting nvidia as prime (also setting cpu as prime and then back)
  • Updating the kernel. It would not update further than 5.4.*
  • Disabling secure boot

1 Answer 1

0

After trying everything related to my issue i decided to try to upgrade my ubuntu version, as this previously fixed issues when i upgraded from 18.* to 20.*. Upgrading to version 22.* fixed the issue!

Here's a guide that shows how to upgrade ahead of time: https://www.omgubuntu.co.uk/2022/04/how-to-upgrade-to-ubuntu-22-04-lts

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.