2

After Ubuntu upgrade to 22.04, the printer Nashuatech Aficio MPC2051 print only in Black/White and doesn't print in COLOR mode:

I tried to reinstall drivers.

In Ubuntu printer setup if i select 'Color' then reopening Ubuntu printer setup I always find 'Grayscale'. It doesn't store 'Color' mode.

I tried running Bash file Test_Stampa_COLORI.sh :

#!/bin/bash
lp -o ColorModel=Color -o media=a4 -o fit-to-page "test_color.pdf"

I tried also using Generic Printer Drivers.

But always print in B/W.

With 21.10 the printer works also in color mode.

Driver selection window

4 Answers 4

11

Thanks to TontonManu that gave me the way.

My solution has been:

open ubuntu printer setup (pulldown menu from top right);

open additional printer setup (clicking on button right side);

open printer property from 'Printer - localhost' (right click on the printer icon);

select 'opzioni lavoro' (job option) schedule;

in this schedule select 'color' in the 'print-color-mode' field (it was monochrome by default).schedule selection

Now it's ok.

(PS: Only for notice using PDF drivers not working at all neither B/W)

4
  • Amazing! This options was set to "monochrome" on most of my printers, probably since I updated to 22.04, Thanks for your solution, it works perfectly!
    – user825976
    Jun 1, 2022 at 21:28
  • ...the strange detail is that this modification is not persistent. I think another application changes this setting; maybe LibreOffice, that I very often use, or the system itself at restart... but I have to check this setting each time I want to print in color.
    – user825976
    Aug 19, 2022 at 23:13
  • I was going through options several times and managed to miss that one every time. Thanks!
    – nobody
    Sep 27, 2022 at 8:30
  • 1
    At last, I've found why the option was not persistent on my computer. I had to edit /etc/cups/printers.conf find my printer and modify the line: Option print-color-mode monochrome →Option print-color-mode color
    – user825976
    Feb 9, 2023 at 20:42
10

This seems to be due to a bug in CUPS:

CUPS 2.4.2 creates new printers with "Option print-color-mode monochrome" as default

See also this report on Launchpad: printing PDF appears always grey, no color

A workaround suggested by a CUPS developer on GitHub is to issue the command:

lpadmin -p PRINTER -o print-color-mode-default=color

1
  • this answer works perfectly, lpstat -p gets you the correct printer name
    – Arno
    Nov 1, 2023 at 17:20
0

I've got exactly the same problem with several RICOH printers (IMC 3000), everything in the configuration parameters looks correct, except for the "color" setting which isn't taken in account in printer setup, as you describe it.

If anybody has any solution, I'm very interested as well.

(EDIT: I've succeeded in printing in colors, after reinstalling the printer, choosing PDF format instead of PS in the drivers list)

3
  • I have 3 drivers format available (one is pdf) and tried all 3 format but stil print in B/W.
    – Emilio
    May 28, 2022 at 15:24
  • Well, I've reproduced my printer installation, and I have color. When your printer is installed, be sure that it uses PDF driver, go to the printer properties to check it. (on a previous itstallation I chose PDF printer but it used PS driver instead)
    – user825976
    Jun 1, 2022 at 1:24
  • Note that libcups2 updated this morning (libcups2_2.3.1-9ubuntu1.2) but it didn't change anything on my PS version of this printer = still black&white. Strange issue...
    – user825976
    Jun 1, 2022 at 1:37
0

Solved B&W 22.04 LTS printing issue installing Gutenprint Printer Application available in the snap store. After installation, https://localhost:8000/, add the printer, and then all other apps can print in colour mode when requested (PDF, Libre and so on).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .