I want to connect via RDP from an Ubuntu 20.04 laptop to an Ubuntu 22.04 desktop.

I've read in the release notes that the 22.04 release support RDP connections. I enabled Remote Desktop sharing in GNOME Settings. However, when I try to connect from my laptop, the Remmina client gets stuck on "Reconnection attempt 1 of 20" (flicking between attempt 0 and 1).

When I look at tutorials on the web for making RDP connections to 22.04, they say we should install xrdp. Is this right? The 22.04 release notes say "RDP is now available for sharing your desktop remotely." If we really have to install an RDP server, what does it mean that "RDP is now available"? How is 22.04 different from previous versions with xrdp installed?

  • Can't really comment on the problem you're having. Also, you don't refer to the page that says RDP capability is "built-in". But it's not unreasonable to have to install a package to enable a feature. Since you don't have to pay money to install it, I don't think the claim is misleading in any way -- just install it. I disagree that just because it exists, that it could be installed "on any Ubuntu version", though. After all, there could be incompatibility issues if you take it to an older version of Ubuntu.
    – Ray
    May 25, 2022 at 11:45
  • @Ray thanks for the comment. I have updated my question with a link to the release notes which state "RDP is now available for sharing your desktop remotely". xrdp is a server that has been available to install on Ubuntu for many years, long before 22.04 was released; for example, it can be installed on 20.04 (and even earlier) using apt install xrdp.
    – k314159
    May 25, 2022 at 11:59
  • Indeed...I looked up xrdf when I first saw your post and I noticed it was available since 18.04. So, I wasn't sure what you meant; I'm also not a user of xrdp, so I couldn't comment about earlier versions.
    – Ray
    May 25, 2022 at 14:12

3 Answers 3


Short answer: Remmina version is too old on 20.04:

Upgrade your laptop to 22.04


uninstall apt remmina and install the flathub version on 20.04

Try connecting with a local RDP client on your 22.04 machine first.

Enter your IP-address and credentials.

Confirmed working here: default app remmina and gnome-connections (apt install gnome-connections)

You should get a connection and an interesting showcase of the Droste-effect

And I had no troubles connecting from another 22.04 machine.

But getting a connection with the same settings from the default 20.04 client is also not working here either, nor from a aFreeRDP Android client

Try the newer flathub remmina version, that is working on 20.04.

sudo apt remove remmina
flatpak install flathub org.remmina.Remmina
flatpak run org.remmina.Remmina

If you get an error that No remote refs found similar to ‘flathub’ you must run flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo before the install command


To quickly provide some info,

Sharing Feature in Ubuntu

Before Ubuntu 22.04,

  • Screen sharing feature was using VNC Protocol.

With Ubuntu 22.04,

  • Screen sharing feature can use RDP or VNC Protocol

Screen sharing feature allow you to give access remotely to a user in read mode or the user can access it in full control. You can secure the connection via a Password.

As far as we know, the Sharing features works when a user is logged in on the local machine. If no-one is logged on, Sharing the screen will not work

xRDP Package

xRDP is a MS Remote Desktop Services alternative or fork. which will support RDP Protocol

To be able to use this software, you will need to install it first on your ubuntu machine by executing the following command

sudo apt-get install xrdp 

When installation is complete,

  • get the hostname or IP Address of your Ubuntu machine.
  • Logout from the Ubuntu machine (No user should be logged into Ubuntu)
  • Go to another machine (Windows or Linux) and start your favorite RDP Client (mstsc or remmina) and specify the ip address/hostname to connect to
  • the xRDP Login page will show up
  • Enter the correct credentials
  • If everything is working as expected, you will see a gnome Desktop and you will be remotely connect to you Ubuntu machine

Important Points

To have exactly the same look'n feel between local desktop and remote desktop, you need to perform some more post-configuration actions

xRDP can be used when no user is logged on locally.

xRDP and Sharing using RDP Protocol cannot be used at the same time as they will use both same port (i.e. 3389)

Hope this help in answering your question about RDP Support in Ubuntu 22.04

  • Thanks, but it doesn't quite answer my question. I am using 22.04, and I can see that it is now supposedly possible to connect with RDP as well as VNC. Prior to 22.04, I could only connect using VNC. Now I can still connect via VNC, but I should be able to connect via RDP too. But my attempts to connect with RDP have so far failed. I shouldn't have to use xRDP - that is something that I could have used in previous versions too. As I understand it, 22.04 brings the ability to connect via RDP without having to install additional software. But it doesn't work.
    – k314159
    Jun 13, 2022 at 19:30
  • 1
    Hello there, to find the issue, I would do... 1/check if the sharing rdp service is up and running (using this command systemctl --user status gnome-remote-desktop.service) - 2/ use a different rdp client (mstsc or remote desktop viewer => if this is working, problem lies with Remminia - 3/ if you really want to use Remmina, double-check remmina connection settings...in the past, reconnecting issue loop caused by wrong or unsupported color depth .... We have tested with remmina and mstsc working fine...hope this help Till next time
    – Griffon
    Jun 19, 2022 at 6:55

I wanted to add: The RDP server is supported in Gnome since Ubuntu 22.04.

However, an RDP server is not supported by KRFB in KDE. A corresponding feature request is here: https://bugs.kde.org/show_bug.cgi?id=455238

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .