45

I read posts that said you can switch at the login screen. But I have no option to switch there.

1
  • 1
    See this link to an answer to other question here at AskUbuntu.
    – sudodus
    Commented May 24, 2022 at 6:43

3 Answers 3

45

You can enable the X using the terminal. Open the terminal and run the command:

$ sudo nano /etc/gdm3/custom.conf

there you will find

WaylandEnable=true

change it to

WaylandEnable=false

And restart the system.

Or you can do the same by following the instructions given in this link here under GNOME heading. Release Notes

7
  • 2
    I actually found "#WaylandEnable=false" and uncommenting it (removing the # to get "WaylandEnable=false") did it
    – giuspen
    Commented Nov 27, 2022 at 12:03
  • 2
    (not your fault) Great; this just broke my system. Apparently my X is broken so now it just can't boot. Commented Dec 21, 2022 at 10:53
  • 1
    I chose the recovery boot option from the Grub menu, booted into a terminal, and undid the change. Commented Dec 21, 2022 at 10:54
  • Yes, my ubuntu could not boot up, so I also had to recovery login as root and undid the change
    – MikeKlemin
    Commented Apr 3, 2023 at 10:26
  • My first reboot, after uncomment #WaylandEnable=false". Ubuntu just halt somewhere in the boot-process (dark screen). Make a hard turn off, and waited five second, and Ubuntu start as normal (with X11). /Cheers
    – joni
    Commented May 31, 2023 at 15:04
20

Update: As @DanglingPointer mentioned in comments below, If you have upgraded the Ubuntu from older version you might be able to change it via the cog wheel as per the steps. If that's not the case, please refer to the steps in Shreedhar Hegde's answer here

On the lock screen,

  1. Once clicked on the password field or after typing your password, look for the cog wheel on the right bottom corner & click on it
  2. Once clicked, you will be presented with two options - Click on the needed mode
    • Ubuntu (Wayland - the default)
    • Ubuntu on XOrg (The second mode - your expected option)
  3. Then just sign-in - You would be logged in to the session on the mode selected

Hope this helps :)

6
  • 3
    No cog wheel on my right bottom at the signin screen, 22.04
    – rearThing
    Commented Sep 19, 2022 at 1:13
  • rearThing, can you share the screenshot of the screen you are referring ?
    – Aravinth
    Commented Sep 21, 2022 at 14:42
  • 3
    @Aravinth I think you can see the cog wheel because you upgraded over several generations. Those on fresh install don't have that option. In my generations upgraded instances, I can see Ubuntu, XOrg, Unity, and Kodi options. Commented Oct 1, 2022 at 1:36
  • @DanglingPointer - Thanks for that insight, I was unaware of it. In my case i have upgraded from 20.04 to 22.04, Maybe due to to that i have it there
    – Aravinth
    Commented Oct 1, 2022 at 18:24
  • @rearThing, Did the Shreedhar Hegde's answer helped in your case?
    – Aravinth
    Commented Oct 1, 2022 at 18:31
1

I read posts that said you can switch at the login screen. But I have no option to switch there.

You may just need to click your username first to begin typing your password. The little gear icon in the bottom-right of the screen, which is how you choose between X and Wayland, only appears after you type in or select your username.

Full instructions from my answer here: "failed to enable link training" when resuming from suspend: Wayland window manager causes my computer to stay on a black/blank screen and not wake up:

Detailed instructions: to use the X11 Window Manager instead of Wayland in Ubuntu 20.04, 22.04, etc.

(originally posted in my answer here):

  1. Log out of Ubuntu.

  2. At the login screen, click your username to begin typing your password.

  3. This enables a little gear icon in the bottom-right, to select your window manager. Click that to select your window manager. Choose the non-Wayland option!

    If currently set to the Wayland option, then it will show "Ubuntu" [which means Wayland in this case] and "Ubuntu on Xorg" [which means X11]. Choose the "Ubuntu on Xorg" option. Here are some screenshots:

    Again, if it shows "Ubuntu" and "Ubuntu on Xorg", choose "Ubuntu on Xorg":

    enter image description here

    But if you are in X11, then it will show "Ubuntu" [X11] and "Ubuntu on Wayland" [Wayland].

    So, if it shows "Ubuntu" and "Ubuntu on Wayland", then choose "Ubuntu":

    enter image description here

  4. Once you are logged in, you can see which window manager is active by going to Ubuntu Settings --> About --> Windowing System, as shown below. I am logged in with the X11 window manager here, as you can see:

    enter image description here

See also

  1. From the bottom of my answer here: Installed Ubuntu 22.04 and I experience frequent freezes and crashes (when using NVIDIA graphics card):

    To use X11, when you reboot and get to the login screen (assuming your computer doesn't automatically log in for you), after you type in or select your username only, there will be a little gear icon in the bottom-right of the login screen. Click it and select the "Ubuntu" option rather than Ubuntu 22.04's default "Ubuntu with Wayalnd" option. The "Ubuntu" option runs the traditional X11 window manager server, whereas the "Ubuntu with Wayland" option runs the newer (and glitchier, in my experience) Wayland window manager server.

  2. I also describe changing from Wayland to X in my answer here: How can I add "Show desktop" to the GNOME dash or Ubuntu Dock?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .