5

I just upgraded from 20.04 to 22.04 on a Lenovo IdeaPad 3 15ITL05. I wanted to use the new screen recorder, so I pressed PrtSc, which brought up the normal options. The screenshot function seems to be working fine, but when I choose to record, the symbol at the top of the screen pops up for a split second, then vanishes and nothing happens. Any ideas about how to fix this??

1
  • 1
    In my case it wasn't working because I had removed "Videos" from ~/.config/user-dirs.dirs and /etc/xdg/user-dirs.defaults .
    – macramole
    Jun 27 at 2:29

1 Answer 1

7

I have a few ideas. I used htop to view my running processes to figure out a little about the Screencast program.
Mine is here "usr/share/gnome-shell/org.gnome.Shell.Screencast" You can run the program and then check a few on your log files and look at the activity.

cd /var/log

The -f option for tails lets you watch whats happening. Or just use tail -n 20 syslog and look at the last 20 lines in the log file.

other ideas...Using different file manager? limited user account? Screencast folder missing? not a Gnome desktop or installed different one?

tail -f syslog

And see if you find anything interesting. Also check auth.log, kern.log, Xorg.1.log, ....

Mine created a folder in /home/userMe/Videos/Screencasts and all my Screencast show up there in WebM format.

Let us know what you figure out

Update: Known issue for upgrades:

Seems that gstreamer-1.0 isn't upgrading correctly and the fix:

cd ~/.cache
rm -rf gstreamer-1.0

or that might work

sudo apt reinstall gstreamer1.0-pipewire
4
  • i too have the same issue & found below in syslog - Any comments? pc dbus-daemon[6329]: [session uid=1000 pid=6329] Activating service name='org.gnome.Shell.Screencast' requested by ':1.38' (uid=1000 pid=6494 comm="/usr/bin/gnome-shell " label="unconfined") pc dbus-daemon[6329]: [session uid=1000 pid=6329] Successfully activated service 'org.gnome.Shell.Screencast' JS LOG: Failed to create pipeline: Gst.ParseError: no element "pipewiresrc" pc gnome-shell[6494]: Error starting screencast pc gnome-shell[6494]: D-Bus client with active sessions vanished
    – Aravinth
    May 24 at 5:26
  • Thanks Czar, it seems like gstreamer was the issue. I reinstalled it and the Screencast program works fine now. May 24 at 16:51
  • 1
    The removal command worked for me, thanks :)
    – Aravinth
    May 27 at 17:17
  • 6
    Just deleting the cached dir fixed it for me: rm -rf ~/.cache/gstreamer-1.0
    – Janghou
    Jun 1 at 18:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.