33

I am trying to install docker-desktop from here. I downloaded the .deb package with:

sudo dpkg -i docker-desktop-4.8.1-amd64.deb

but I got a couple of missing dependencies problems:

(Reading database ... 422535 files and directories currently installed.)
Preparing to unpack docker-desktop-4.8.1-amd64.deb ...
Unpacking docker-desktop (4.8.1-78998) over (4.8.1-78998) ...
dpkg: dependency problems prevent configuration of docker-desktop:
 docker-desktop depends on docker-ce-cli; however:
  Package docker-ce-cli is not installed.
 docker-desktop depends on pass; however:
  Package pass is not installed.

dpkg: error processing package docker-desktop (--install):
 dependency problems - leaving unconfigured
Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu3) ...
Processing triggers for desktop-file-utils (0.26-1ubuntu3) ...
Processing triggers for bamfdaemon (0.5.6+22.04.20220217-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Errors were encountered while processing:
 docker-desktop

I Have tried to install the missing dependencies using:

sudo apt-get -f install

But it still returns the same error message as above.

2
  • 1
    I personally bumped into the missing dependencies pass and uidmap on my Ubuntu 22.04 (to which I upgraded the hour before). In the end I found out that the Universe packages of Ubuntu were no longer loaded. Check the Software Settings in Ubuntu to make sure the packages from Universe are searched as well. Aug 23, 2022 at 17:29
  • sudo apt install ~/.../docker-desktop-4.8.1-amd64.deb. Then you may get prompted to sudo apt --fix-broken install. Then do the first again, and it will run.
    – Johan
    Dec 21, 2023 at 14:32

6 Answers 6

56

You can fix this by running the following commands:

  1. Update and install dependencies

    sudo apt-get update
    sudo apt-get install ca-certificates curl gnupg lsb-release
    
  2. Set up the Docker repository

    sudo mkdir -p /etc/apt/keyrings
    curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo gpg --dearmor -o /etc/apt/keyrings/docker.gpg
    echo "deb [arch=$(dpkg --print-architecture) signed-by=/etc/apt/keyrings/docker.gpg] https://download.docker.com/linux/ubuntu $(lsb_release -cs) stable" | sudo tee /etc/apt/sources.list.d/docker.list > /dev/null
    
  3. Install the docker engine

    sudo apt update
    sudo apt-get install docker-ce docker-ce-cli containerd.io docker-compose-plugin
    
  4. Install Docker Desktop (You must download the deb package first from step 2 from the following document: Install Docker Dekstop)

    sudo apt-get install ./docker-desktop-<version>-<arch>.deb
    

More info here:

7
  • Thanks, these steps worked well. There were other good answers, but incomplete.
    – vrijdenker
    Jun 19, 2022 at 19:05
  • After following the instructions of Nafiu Lawal , till step 6, you do not need to manually install docker-ce docker-ce-cli containerd.io docker-compose-plugin . Just got ahead with sudo apt install ./<docker-package-name>.deb after doing sudo apt update.
    – Ari_12
    Jun 26, 2022 at 16:03
  • I can concur that these steps worked, though after step 6, you can just proceed to step 8, using apt install to point to the .deb file. And if it's not clear to readers, note that those first 5 steps Nafiu offered are indeed from the Docker docs, and the Docker Desktop docs point to this need to update the repository (docs.docker.com/desktop/linux/install/debian/…), pointing to the page Nafiu had. Beware that you must do that step 6 before proceeding to step 8. Jun 29, 2022 at 17:39
  • 1
    Step 8: sudo apt-get install ./docker-desktop-4.12.0-amd64.deb and I get Reading package lists... Done E: Unsupported file ./docker-desktop-4.12.0-amd64.deb given on commandline I admit I'm on Ubuntu 20.04 . . .
    – Trunk
    Sep 2, 2022 at 23:58
  • 1
    @Trunk How you solved this issue? I am also getting this error.
    – Tanishka
    Oct 27, 2022 at 10:51
8

Docker Desktop relies on some packages found in the universe repository. So this needs to be added if it's not already present:

sudo add-apt-repository universe

Then, follow along with these instructions.

Use this command to install: sudo apt-get install ./docker-desktop-<version>-<arch>.deb, and your dependencies will be resolved during installation for you.

dpkg is a low-level tool, that does not automatically resolve dependencies. apt-get (and apt) are higher-level tools that use dpkg, but also resolve dependencies for you.

2
  • 5
    I followed these exact instructions using sudo apt-get and I get the same error as OP
    – Caustic
    May 25, 2022 at 2:53
  • Adding the universe repo should increase the chance of success! Feb 8, 2023 at 11:00
2

I tried some of the above solutions but they did not work for me. Hence what I did, I went to the site and first installed the Docker Engine and then installed the Docker Desktop and it worked

Kindly follow these instructions as indicated on the website to download the Docker engine and then go ahead and download the Docker Desktop

That's what worked for me.

1

I had the same problem
I fixed it by iinstalling a docker engine https://docs.docker.com/engine/install/ubuntu/#set-up-the-repository
sudo apt install docker-ce docker-ce-cli containerd.io docker-compose-plugin

then sudo apt-get install ./docker-desktop-<version>-<arch>.deb

0
1

If none of the above answer works, simply try this and it will install 100% :

sudo apt --fix-broken install ./docker-desktop-4.10.1-amd64.deb

Just change the .deb filename to what you have downloaded.

1

Installed docker desktop on Ubuntu 22 migrated from Ubuntu 20, following official instructions https://docs.docker.com/desktop/install/ubuntu/ as mentioned above, and had this error

Note, selecting 'docker-desktop' instead of './docker-desktop-4.12.0-amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qemu-system-x86-xen : Conflicts: qemu-system-x86 but 1:6.2+dfsg-2ubuntu6.3 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

And solved installing this package

$ sudo apt install qemu-system-x86

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .