2

There have been some upgrades of kernel and/or NVIDIA packages on my laptop (Ubuntu 20.04, the normal upgrade popups that occur from time to time). After a reboot I now get a blank screen and this error in /var/log/Xorg.0.log:

[    27.640] (EE) NVIDIA(0): The NVIDIA X driver has encountered an error; attempting to
[    27.640] (EE) NVIDIA(0):     recover...
[    27.654] (EE) NVIDIA(GPU-0): Failed to allocate notification memory.
[    27.654] (EE) NVIDIA(0): Failed to allocate push buffer
[    27.654] (EE) NVIDIA(0): Error recovery failed.
[    27.654] (EE) NVIDIA(0):  *** Aborting ***

It was working with the old nvidia-driver-460 before. But now with nvidia-driver-470 I get this error - I also tried nvidia-driver-510 but this give the same error. I also tried a different kernel version, but also same error. So it must be nvidia itself.

Now I thought of downgrading back to nvidia-driver-460 but this is now only a transitional package for the 470 version:

apt show nvidia-driver-460
Package: nvidia-driver-460
Version: 470.103.01-0ubuntu0.20.04.1
Priority: optional
Section: restricted/libs
Source: nvidia-graphics-drivers-470
Origin: Ubuntu
Maintainer: Ubuntu Core Developers <[email protected]>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 20,5 kB
Depends: nvidia-driver-470
Homepage: http://www.nvidia.com
Download-Size: 7.156 B
APT-Manual-Installed: yes
APT-Sources: http://de.archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages
Description: Transitional package for nvidia-driver-470
 This is a transitional package for nvidia-driver-470, and can be
 safely removed after the installation is complete.

So my usual downgrade procedure I did in the past whenever there was an NVIDIA problem was this:

sudo apt-get purge *nvidia*
sudo apt-get install nvidia-driver-460

But the last step - because it is a transitional package - now again installs the buggy 470 version.

0

You must log in to answer this question.

Browse other questions tagged .