0

I imported both Ubuntu 20.04 and 22.04 OVA into vSphere like this:

govc import.ova -name ubuntu-20.04-server-cloudimg-amd64-md -folder vm/DIA_RnD/RMD/buildenvironment/templates https://cloud-images.ubuntu.com/releases/releases/20.04/release/ubuntu-20.04-server-cloudimg-amd64.ova
govc import.ova -name ubuntu-22.04-server-cloudimg-amd64-md -folder vm/DIA_RnD/RMD/buildenvironment/templates https://cloud-images.ubuntu.com/releases/releases/22.04/release/ubuntu-22.04-server-cloudimg-amd64.ova

For Ubuntu 20.04 the VM created from the template works and gets an IP: 20.04 vSphere

For Ubuntu 22.04 the VM does not get an IP: 22.04 vSphere

I have also tried to use import.spec and pass the options json file but same result, it works for 20.04 but not for 22.04.

govc import.spec ubuntu-22.04-server-cloudimg-amd64.ova | jq . > 2204.json
govc import.ova -name ubuntu-22.04-server-cloudimg-amd64-md -options 2204.json -folder vm/DIA_RnD/RMD/buildenvironment/templates https://cloud-images.ubuntu.com/releases/releases/22.04/release/ubuntu-22.04-server-cloudimg-amd64.ova

Many thanks in advance.

1 Answer 1

2

After you import the cloud-image template and before converting it to a template, you may have to enable the OVF environment.

Go to ConfigureSettingsvApp Options and enable OVF environment for the IP allocation scheme, as well as VMware Tools under OVF Details.

After that, convert the modified VM to a template and deploy new VMs using that template.

2
  • Thank you very much, that worked. Now I have to figure out how to automate this. May 17, 2022 at 2:50
  • This doesn't seem to work for me in vCenter, unfortunately :( Oct 19, 2022 at 23:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.