0

After an update, my desktop environment stopped working. Check this question of mine for more details, the problem and the fixes I've tried such as reinstalling nvidia drivers. It turns out that there's something wrong with gnome-shell since I'm using unity now and everything's alright.
When I login to my account with gnome desktop, nothing appears on the screen, just the purple focal fossa stays there which is the background of lightdm login screen. So I need to switch to TTY3 and set $DISPLAY to :0 which is set to blank with every login for some reason I don't know. Then I can run the required command to run a GUI app like Firefox and VLC with TTY3 and then switch to TTY7 to use it graphically. But when I run gnome-shell I get the following error:
(gnome-shell:10075): Gjs-WARNING **: 00:41:32.092: JS ERROR: Requiring Clutter, version 6: Typelib file for namespace 'cairo', version '1.0' not found @resource:///org/gnome/shell/ui/environment.js:13:58
** Message: 00:41:32.892: Execution of main.js threw exception: Script <main> threw an excpetion
I tried to install some required dependencies suggested here and here but nothing changes. Seems like some bugs like that has been reported before like this . How can I get gnome to work again?
I will try to post any required information ASAP.

New contributor
AliAndArdDev is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

0

Your Answer

AliAndArdDev is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.