0

I recently lost my NAS and am trying to recover the data in my RAID. The disks are fine, its just the NAS hardware that stopped booting and I can't get any support as its discontinued.

I attached the disks to my Ubuntu machine and can see the following info:

sudo mdadm --detail /dev/md126
/dev/md126:
           Version : 1.2
     Creation Time : Sun Jan 10 09:57:09 2016
        Raid Level : raid5
        Array Size : 8776244352 (8.17 TiB 8.99 TB)
     Used Dev Size : 2925414784 (2.72 TiB 3.00 TB)
      Raid Devices : 4
     Total Devices : 4
       Persistence : Superblock is persistent

       Update Time : Fri May  6 07:03:58 2022
             State : clean 
    Active Devices : 4
   Working Devices : 4
    Failed Devices : 0
     Spare Devices : 0

            Layout : left-symmetric
        Chunk Size : 64K

Consistency Policy : resync

              Name : 0e342a28:data-0
              UUID : c1d1d0bb:08037d20:54ea1137:054d8bb7
            Events : 748

    Number   Major   Minor   RaidDevice State
       0       8       67        0      active sync   /dev/sde3
       1       8       51        1      active sync   /dev/sdd3
       2       8       35        2      active sync   /dev/sdc3
       3       8       19        3      active sync   /dev/sdb3

However, mdadm.config is emtpy and running the usual --scan commands doesn't return any results. I have tried using -assamble while passing on all disks as parameters but I get this result:

sudo mdadm --assemble /dev/md126 /dev/sdb3 /dev/sdc3 /dev/sdd3 /dev/sde3mdadm: /dev/sdb3 is busy - skipping
mdadm: /dev/sdc3 is busy - skipping
mdadm: /dev/sdd3 is busy - skipping
mdadm: /dev/sde3 is busy - skipping

I just want to get it mounted so that I can copy the data to the new NAS. Can anyone help with this?

Thanks, Alex

Edit 1: as per suggestion in comments, I have checked it with file:

sudo file -sL /dev/md126
/dev/md126: BTRFS Filesystem label "0e342a28:data", sectorsize 4096, nodesize 32768, leafsize 32768, UUID=d9f1e416-0a37-4425-9037-a35e229ba477, 8453121372160/8986874216448 bytes used, 1 devices
New contributor
duskiez is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
2
  • It looks like it is assembled (as /dev/md126) but not mounted - have you tried something like sudo file -sL /dev/md126 to see if it contains a recognized filesystem? yesterday
  • OK so have you tried mounting it manually? sudo mkdir -p /mnt/nas && sudo mount -o ro /dev/md126 /mnt/nas for example? What are the error messages (if any)? What version of Ubuntu are you using? yesterday

0

Your Answer

duskiez is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.