2

4 days ago, I decided to install the update that "Software and Updates" has been suggesting for a while. After the progress dialog was gone, I closed the laptop lid, expecting it to sleep(didn't shutdown) but when I opened it, the computer was absolutely unresponsive with some text on a black screen. So I needed to force shutdown with power button, but then I powered on and it was fine. The next day, I turned computer on and I was directed to busybox. Running fsck /dev/sda2 which is my root partition, some corruption on system files were detected and fixed. After a reboot and ubuntu logo with the circular progressbar showing up, a sequence of black screen with a blinkng cursor, replaced by a black screen with a mouse cursor, would keep me away from login screen. So these are what I've done so far through TTY:

  • completing the upgrade following: https://askubuntu.com/a/1239036/1572653 Also tested sudo apt --fix-broken install and sudo dpkg --configure -a
  • reinstalling grub following: https://www.linux.org/threads/urgent-linux-system-not-loading-up-login-page.32370/post-110166 This thread is very similar to my case.
  • Changing display manager from gdm3 to lightdm. Doing this, the login screen appears, but after entering the password, "Oh no something has gone wrong" stops me again. I even tested xdm. In this case, the login screen appears, but then, just black screen.
  • purging and reinstalling nvidia drivers and xorg and gnome following: https://askubuntu.com/a/760935/1572653
  • manipulating grub and changing quite spalsh to nomodeset following: https://askubuntu.com/a/111298/1572653
  • using startx , the operation terminates in a blink of an eye without any errors. However everything's fine according to https://askubuntu.com/a/223634/1572653 I tried a few more solutions found on this thread. .xsession-erros and Xorg.1.log files seems to be useful but no idea what to look for in them
  • suspecting an issue with the upgraded nvidia driver, I downgraded it to 470 from 510(I've used both versions before all this happens)
  • suspecting an incompatibility between the upgraded kernel (version 5.13.0-41) and nvidia drivers. So I reinstalled the old kernel(5.11.0-27) which was deleted by autoremove. But I don't have internet connection when I boot to 5.11.0-27 to install anything there. Actually nmcli dev wifi list shows no available network, while it does on 5.13.0-41. Anyone has a clue why?
  • fsck -a /dev/sda1 which is my /boot/efi partition. It reports dirty bit. The outputs are exactly the same as the question here: fsck Dirty Bit Reported but when I choose to fix them, they're still there the next time I reboot.

After all, I'm still facing "Oh no something has gone wrong" with lightdm and the black screen of blinkng cursor with gdm3.

A few more notes :

  • Secure boot is disabled, since it was the case for a few
  • I disconnected my coolpad cable from laptop, since such things like HDMI and USB cables being connected was the case for a few and something weird happened. Now I can hear a bloop sound everytime lightdm login screen shows up, like when you disconnect a USB cable. The sound wasn't there before.(Probably not that useful)
  • I have just one user account on ubuntu.
  • system details: Lenovo ideapad 310 _ Ubuntu 20.04 LTS _ CPU: Intel Core i5-7200U 2.5GHz _ 8GB Ram _ HDD 1TB _ NVIDIA Geforce 920MX
  • I know there are questions like this on the forum, but hoping the very details I provide work something out.

I will try to append any required information such as output of a command ASAP.

/var/log/demsg: https://pastebin.ubuntu.com/p/bNRn2VdBnH/

My repos: https://pastebin.ubuntu.com/p/ztFcWv863X/

.xsession-errors: https://pastebin.ubuntu.com/p/z7TsRSzmK6/

First 6000 lines of syslog(as much as I could): https://pastebin.ubuntu.com/p/59mYPnWTxx/

Xorg.1.log: https://pastebin.ubuntu.com/p/fWJcNK9Kf6/

Output of sudo lshw -c video : https://pastebin.ubuntu.com/p/McFPzYp9Nv/ Doesn't this mean anything? Why two items are listed? Any possibility of contradiction?

UPDATE :
Following this answer I cteated another account and deleted ~/.config for both. The "Oh no something has gone wrong" goes away and the welcome screen that appears at the very first time you install ubuntu shows up, as a small box at the top corner of the screen(including livepatch setup, help improving ubuntu and stuff). It's expandable, like any other application window. In this window everything's fine(clicking, right click and whatever) but nothing else for the rest of the screen, just the focal fossa background that is visible on lightdm login screen. Any hint?

UPDATE: echo $DISPLAY prints blank

8
  • Can you post your xsession-errors and your /var/log/dmesg and /var/log/syslog files somewhere (like pastebin or a github gist). It seems to be you've exhausted all the obvious paths. You've also made an excellent well laid out post, fwiw. Also, do you have any non-standard repos for apt?
    – pbhj
    May 13 at 14:38
  • How can I copy the contents of those files without gui and paste it in ubuntu paste bin? Seems to be a project itself. I will check my apt repos asap. May 13 at 15:00
  • /var/log/dmesg: pastebin.ubuntu.com/p/bNRn2VdBnH May 13 at 15:26
  • Please add the link to pastebin upload in your question. In general always update the question with the new information as and when we ask for them.
    – user68186
    May 13 at 15:36
  • 1
    Well, briefly, as it seems you worked around it(?) but "interfaces file /etc/network/interfaces doesn't exist" is in your syslog and might well explain why your networking wasn't working (I'd start by purging and reinstalling systemd.networking for that). Also in xsession-errors it says "open /dev/dri/card0: No such file or directory" and "Screen 0 deleted because of no matching config section." those seem like your Nvidia install didn't configure your system properly and you're running on a framebuffer. Might be as simple as removing xorg.conf, probably needs some xrandr settings made.
    – pbhj
    May 14 at 21:41

1 Answer 1

1

It took me a century to figure out that gnome-shell is problematic here. For some reason I don't know, $DISPLAY variable is set to null(blank) whenever I logged into gnome desktop environment. So I needed to set this variable to :0 every time through TTY3. Then, by running the command to start a graphical app like Firefox and VLC in TTY3 and switching to TTY7(graphical environment) I could use that application with GUI. But now I'm too exhausted to investigate gnome problem, so installed unity and everything's fine with that. However I posted gnome question here in case you're curious, considering the probability of a bug: Ubuntu 20.04 gnome-shell fails to start

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.