0

I'm using Ubuntu 22.04 LTS. Sometimes when I run a heavy process my CPU temperature reaches 90-95 Centigrade degree but fan speed is 4500RPM, sometimes I saw fan runs up to 5100RPM but at highest temperature it ever reached (95 Centigrade degree), It doesn't use the maximum speed it can. Why and How to fix it?
By the Way How bad is 95 Centigrade degree?

I use ASUSTeK COMPUTER INC. VivoBook_ASUSLaptop X512FLC_R564FL laptop.
My CPU: Intel® Core™ i7-10510U CPU @ 1.80GHz × 8

98 degree but only 4500 rpm

3
  • 1
    ASUS motherboards have very good QFan Control in the BIOS. The issue is that they don't use the actual processor package temperature as the input to the fan control loop servo, and the difference can be significant. 12 degrees centigrade for my Prime Z490-A motherboard, under my test conditions. Demanding users need to compensate for this error. I do not know if ASUS laptops use the same fan control method. I do not let my processor go over 75 degrees Centigrade. May 12 at 19:05
  • @DougSmythies I only have 2 Firefox tabs open and my CPU temperature is 72-78. I don't know what to do anymore. I had this problem in windows too. May 12 at 19:31
  • @Mohammad Mahdi, if you haven't already install TLP or thermald, you might want to give them a try. These two are the common apps used for power control/overheating. However, these are for generic heating issues, if yours is hardware related issues; there will be limitation on how much those apps can help. May 13 at 2:22

1 Answer 1

0

Note you can now choose a power profile in settings. Maybe choose high perf. for your case.

Balanced -> Performance

1
  • I tried, not only it doesn't increase the fan speed, but it also raises the CPU temperature May 12 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.