3

An on-screen keyboard is showing up every time I touch a text field when I use an external monitor with touchscreen. I don't want/need this feature since I have a physical keyboard.

Here's a picture of the virtual keyboard:

The VKB showing up

I read a lot about this issue, but didn't find any solution. I tried the gnome-extension "Block Caribou" but it's not working. Also, the extension was only tested on gnome 3.26 according to gnome-extensions website, so not sure if it's working properly on my system.

Block-Caribou enabled

Also, the on-screen keyboard is disabled in the accessibility settings (on the desktop and on the log-in screen). I think this keyboard must be located somewhere in my system and it should be possible to disable it if I would know where to look at.

System: Ubuntu 20.04.4 LTS with Gnome 3.36.8

Any help or ideas are very welcome.

EDIT: I'll summarize here the comments below. onboard, caribou and florence are not installed in my system as shown by the dpkg -L command. I did not install any virtual keyboard manually (for example as gnome-extension). Only for this purpose and as a workaround I tried installing caribou and enabling again the BlockCaribou extension in the hope that it would block the new installed keyboard. It didn't work. I removed completely caribou. Any other ideas?

15
  • There are a number of virtual screen keyboards in Ubuntu such as onboard, caribou florence and gnome shell's own VKB. Does it look like this how2shout.com/wp-content/uploads/2020/04/…
    – kenn
    May 12 at 11:09
  • It's gnome-shell-extension-onboard. You can see it's content with dpkg -L gnome-shell-extension-onboard
    – kenn
    May 12 at 21:23
  • This is a good point thanks for your help. The problem now is that gnome-shell-extension-onboard doesn't seem to be installed in my system. The command you gave says "not installed". Also dpkg -l | grep "gnome-shell-extension" returns gnome-shell-extension-appindicator, gnome-shell-extension-desktop-icons, gnome-shell-extension-prefs, gnome-shell-extension-ubuntu-dock, gnome-shell-extensions. So where does it hide? I looked in gnome-shell-extensions but couldn't find anything that made me think of a keyboard... May 13 at 9:12
  • Did you install any virtual keyboard from gnome-extensions such as extensions.gnome.org/extension/3330/improved-onscreen-keyboard
    – kenn
    May 13 at 9:14
  • According to the description for gnome-shell-extension-onboard it's not the keyboard, just a button that lets you control it. Installing that might let you pop it down. The real keyboard is onboard
    – user10489
    May 13 at 11:27

2 Answers 2

2

As of Ubuntu 20.04.4 LTS with Gnome 3.36.8 block caribou extension by @keringar won't work. Instead of it use recent version of it by @lxylxy123456

0

I've had a similar situation in the past but it wasn't when using an external screen so maybe not be linked to your issue.

My problem was caused by having the accessibility on-screen keyboard enabled on the initial login screen. This setting is separate from the one in the settings found when logged in.

Log out of your user profile and at the top right of the screen you'll see a stick-man figure in a white circle. Click on that and you'll get a drop down menu and ensure the on-screen keyboard is off. Then log back into your user profile and try your touchscreen click in a text box again.

This fixed my issue but like I say this may not be the same thing for you. Hope it helps.

1
  • Thanks for your idea. I didn't know that these are two different settings. Unfortunately it didn't fix my problem since it was already disabled. Jun 10 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.