0

As the title suggest, i want to start the command Iperf -s ipxxxx when i boot the pc up headless. i've tried to set the Start Application to run the bash script and also tried to write a Systemctl fix as showed in earlier answers to this smiliar problem.

the following is what i've done so far. But nothing is working. sudo nano /etc/systemd/system/iperf3.service

[Unit]
Description=iperf3 server
After=syslog.target network.target auditd.service

[Service]
ExecStart=/usr/bin/iperf3 -s

[Install]
WantedBy=multi-user.target

and after enable the service sudo systemctl enable iperf3

I've also tried to write it in Crontab -e

@reboot root sh /home/test-1/s1.sh

the script i've tried to run "s1.sh" is as follows

iperf -s 192.x.x.x.x -P 2 -t 30 -b 10G -u
2

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.