7

I have a fresh install of Ubuntu 22.04 on a new laptop, with no other OS installed. When I connect to my monitor with the laptop open (so that the built-in display is active) everything freezes - I can't even move my mouse pointer. If I close the lid, the monitor works (the system responds and I can continue). How can I use both screens at the same time?

More information:

  • I have a Framework laptop and have followed Framework's Ubuntu 22.04 installation guide, installing the 22.04 LTS ISO using balenaEtcher
  • Laptop screen resolution is 2256 x 1504 (3:2)
  • My monitor is an ASUS ProArt Display PA278QV
  • Monitor resolution is 2560 x 1440 (16:9)
  • I'm connecting mini-DP (monitor-end) to DP (laptop-end) via a Framework-specific DisplayPort expansion card
  • The monitor works as one of multiple displays when connected to my Windows desktop PC
  • I have my laptop display set up to use 100% scale, but after connecting the monitor it reverts to 200%
  • After connecting via display port, my desktop background is displayed on the external monitor, so clearly Ubuntu starts to send some display data to it before things go wrong.
  • Sometimes some of the windows I have open on my desktop are displayed on the monitor, sometimes they remain on my laptop screen

Happy to share more information and diagnostics on request (wasn't sure what other information would be helpful). Thanks in advance for any answers or hints!

Update 1

When using x11 (enabled via instructions from linuxconfig.org), the monitor is not detected when plugged in.

The output from sudo lshw -c video is

  *-display                 
       description: VGA compatible controller
       product: TigerLake-LP GT2 [Iris Xe Graphics]
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       logical name: /dev/fb0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=i915 latency=0 mode=2256x1504 resolution=2256,1504 visual=truecolor xres=2256 yres=1504
       resources: iomemory:600-5ff iomemory:400-3ff irq:190 memory:605c000000-605cffffff memory:4000000000-400fffffff ioport:3000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff

Update 2

ubuntu-drivers list returns nothing.

The Additional Drivers tab of the Software & Updates application shows "No additional drivers available" - see screenshot of Additional Drivers tab of Software & Updates app (I don't have the reputation to embed images into posts). This is despite having the main, universe, restricted and multiverse package repositories enabled and a working internet connection. This happens with various choices of server.

Update 3

Reinstalling hasn't helped. Interestingly, when I run "Try Ubuntu" from the bootable USB device, I can connect the monitor and have Ubuntu working on both screens. It seems that, somehow, the problem is with the installed OS, rather than the OS itself.

Update 4

I've installed Ubuntu 20.04.4 and the laptop screen and monitor work together.

19
  • Kindly check what graphic driver your laptop is running. Sometimes the driver and/or the graphic card aren't able to handle the higher resolution monitor with build-in display running at the same time. Or if you are using wayland, switching to x11 to do the testing will make it easier to do testing since wayland is still glitchy. The first thing i'd do is login with x11, next go into setting and use the display GUI and work from there. Last on the list is switching between different drivers. May 9 at 21:14
  • Thanks @ManOnTheMoon. I've updated my answer with some information. Where can I find alternative drivers and how do I know which are suitable?
    – mattg
    May 9 at 21:46
  • you can find the drivers selection using the software & update GUI in the show application shortcut. Then click the Additional drivers tab. As for which is/are suitable, you should be able to find the details on the vendors' site. However, with the new 22.04, you'd probably have to trial and error them all. Before switching between drivers, remember to work with the display GUI. For example using your current driver, try all the options in the display GUI then switch driver and try all the options in the display GUI. rinse and repeat. May 10 at 9:09
  • Personally, I'd try the Nouveau display driver(open source) first and tweak the display GUI. If it works, it confirms it's a driver issue. And all it left to do is finding the most to date and driver that works. May 10 at 9:15
  • 1
    @ManOnTheMoon Yes, I have main, universe, restricted and multiverse package repositories selected. Yes, I have internet connection from the laptop (it's the device I'm using Ask Ubuntu from). I have reinstalled - first time I used default settings, second time I checked the enable third-party software box, thinking that that might resolve the issue. It didn't. Switching servers doesn't seem to have helped either. Thanks for your help so far, it's much appreciated :)
    – mattg
    May 10 at 12:55

2 Answers 2

3

I ran into a similar issue using Ubuntu 22.04 on a dual booted machine with an Intel Skylake GT2 [HD Graphics 520] card. Disabling Wayland before logging in as shown here solved the issue for me.

3
  • Thanks KT12. Unfortunately, using Xorg doesn't solve the problem for me.
    – mattg
    Jun 10 at 9:17
  • It solved mine.
    – sw.
    Jun 11 at 15:55
  • This solved it for me as well. Thank you @KT12!
    – Ned
    Jun 16 at 0:51
2

I had a similar issue (second monitor unresponsive) and it was resolved by selecting the nvidia driver in software and updates app.

screenshot

4
  • In the comments I said the problem also happens if no GPU is available (except the Intel integrated graphics) so the problem is more generic and I think the solution should be so.
    – sw.
    May 25 at 15:45
  • in my case exactly the same driver is selected, but Ubuntu 22.04 freezes anyway if external monitor is attached
    – vak
    Jun 10 at 8:40
  • Thanks Ashish, unfortunately I don't have any other drivers shown under additional drivers (I use integrated Intel graphics)
    – mattg
    Jun 10 at 9:18
  • This worked for me Jun 20 at 1:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.