22

Switching language settings made by Tweaks tool (gnome-tweak-tool) like described in accepted answer here.

After performing update to release version by

sudo apt update && sudo apt upgrade

language switching by Alt + Shift stopped working. How to fix it?

Related question: How to have Alt+Shift shortcut for language switching and be able to use other shortcuts that contain Alt+Shift combination keys?

5
  • 1
    This is another of the myriad bugs in Wayland. Select normal non-Wayland (i.e. Xorg) Ubuntu session during login.
    – FedKad
    Commented May 9, 2022 at 14:00
  • @FedKad I also noticed after moving from Ubuntu 20.04 to 22.04 that temperature of working processor got a bit higher. Probably the reason also because of Wayland. Commented May 9, 2022 at 14:22
  • 1
    The rise in temperature, CPU, and memory consumption is probably due to tracker. You can Google "ubuntu disable tracker 22.04" to remove it.
    – FedKad
    Commented May 9, 2022 at 14:45
  • 1
    As @FedKad mentioned, this is most likely a bug. Probably bug #1956916. Please feel free to add observations to that bug report, if you think they may be helpful to the investigation. Commented May 9, 2022 at 15:28
  • I confirm that as @FedKas said there are no problems with switching language under Ubuntu Xorg. Commented May 10, 2022 at 10:05

6 Answers 6

50

Execute the following line by line in terminal on Ubuntu 22 LTS:

gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Shift>Alt_L']"
gsettings set org.gnome.desktop.wm.keybindings switch-input-source-backward "['<Alt>Shift_L']"

Open Settings > Keyboard > Keyboard Shortcuts (View and Customise Shortcuts) > Typing to confirm changes.

keyboard shortcut settings

As noted by @egelev you can choose to forward switch the language or backwards only by assigning multiple key sequences to the same shortcut. This may be convenient if you have more than two languages and want a strict loop clockwise:

gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Alt>Shift_L', '<Shift>Alt_L']"
gsettings set org.gnome.desktop.wm.keybindings switch-input-source-backward "[]"

or counterclockwise:

gsettings set org.gnome.desktop.wm.keybindings switch-input-source "[]"
gsettings set org.gnome.desktop.wm.keybindings switch-input-source-backward "['<Alt>Shift_L', '<Shift>Alt_L']"

Source: https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1956916/comments/38

5
  • 6
    Thanks for the answer! Based on it I'm at last was able to get to work other shortcuts containing Alt + Shift. Here is related question and answer - askubuntu.com/a/1434468/1548713 Commented Oct 8, 2022 at 18:05
  • 4
    Looks like there is no way to set this combination using UI. Thanks) Commented May 6, 2023 at 19:00
  • This should be the accepted answer
    – ribitskiyb
    Commented Jan 30 at 18:08
  • 3
    Obiously, the order matters, so I made use of the array format and set these combinations: "['<Alt>Shift_L', '<Shift>Alt_L']"
    – egelev
    Commented May 10 at 9:31
  • 1
    @egelev thanks for the hint! I have added this as a note.
    – igor
    Commented Jul 5 at 21:54
14

Like in recommended setup:

  • Launch Tweaks tool
  • Go to Keyboard & Mouse section.
  • Click on the Additional Layout Options. A new window should pop up.
  • Look for Switching to another layout and expand it.

Here uncheck all checked options. Check Alt+Shift option again. Leave only one this option. Or only Ctrl+Shift if you prefer to use it.

After this Alt + Shift started working for me but in top right corner of the screen there was no information about corresponding switch - seems to bug introduced in Ubuntu 22.04. In Ubuntu 20.04 this function worked fine.

Win + Space also works normally (with updating of corresponding information about current language in top right corner) even if unchecked in Tweeks.

2
9
  1. Use gnome-tweaks to set shortcut
  2. For Ubuntu 22.04: Open /etc/gdm3/custom.conf and uncomment WaylandEnable=false than save it and reboot. This step makes layout indication work. (and xdotool too...)
3

Look at https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1956916/comments/38

In short:
Use dconf editor, navigate to org.gnome.desktop.wm.keybindings.switch-input-source and set it to '<Alt>Shift_L'

3

Here it is for Alt-Shift / Shift-Alt on both keyboard sides

gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Alt>Shift_L', '<Shift>Alt_L', '<Alt>Shift_R', '<Shift>Alt_R']"
1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Apr 27, 2023 at 10:01
-1

For Ubuntu 24.04 there is a shortcut for switching between keyboard input languages. Use shortcut keys Super + Space and Shift + Super + Space to go back and forth.

Go to Settings > Keyboard > Keyboard Shortcuts > View and Customize Shortcuts and choose Typing. There you can find more useful shortcuts.

enter image description here

New contributor
Muhammad Shahbaz is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • 2
    OP is already aware that those shortcuts exist. They specifically want to use Alt-Shift.
    – muru
    Commented Jul 17 at 4:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .