I was wondering if the following setup is possible using Ubuntu (server) and Ubuntu (workstation):

I have two workstations with Thunderbird as mail client I have one server

On both workstations I want the mail to be synchronized so when I write an email it will appear in the "sent" folder of the second computer too. Also when I am not near my workstation and login to the server (remote) I want to be able to write an email with the same result as above.

I figured out that I need to install Thunderbird on both workstations and on the server, then I need to link the mail file to all 3 clients. The question is "How do I do that?"

Perhaps this question is answered before, in that case I am sorry for asking again.

With kind regards, Marchel.

-EDIT- I found this on MozillaZine: Install Thunderbird separately on each computer but store your profile on a portable USB device or on a network file share. To launch Thunderbird with that profile, use the -profile "path" command line argument.

Is it just straightforward installing or is there something I need to beware of?

(sorry for my bad english)

  • 1
    Have you tried IMAP?
    – mreq
    May 22, 2012 at 14:22

2 Answers 2


The simplest and best solution is configuring all your email clients to use IMAP, if your mail service supports it.

If IMAP isn't supported by your email service, you have a few options:

  1. Store your Thunderbird profile in Ubuntu One.
  2. Store your Thunderbird profile on the server, and share it via SSHFS/CIFS/NFS. It's usually desirably to do this as part of a more general SSO solution.
  3. Synchronize the Thunderbird profiles with a file sync utility such as Unison.
  • IMAP could be a solution but has the same functionality as the web interface of my ISP. I want to be able to use the same layout (signature etc) from wherever I am. That's why I thought about installing Thunderbird client on a server which I can logon to from any location. May 22, 2012 at 14:57

you can also store the profiles folder


into your dropbox and enter the location in the profiles.ini. Make sure u set isRelative to 0 if you use an absolute path.

Works for years for me now on many many machines. =)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.