8

I have tried every solution on this website and none of them have worked. When I type steam in the terminal, this is what I see:

$ steam
steam.sh[21591]: Running Steam on ubuntu 22.04 64-bit
steam.sh[21591]: STEAM_RUNTIME is enabled automatically
setup.sh[21661]: Steam runtime environment up-to-date!
steam.sh[21591]: Steam client's requirements are satisfied

then, nothing happens. It exits and returns control back to the shell.

Please help.

1
  • 1
    Are you running Wayland or X11/Xorg? Video card? Nvidia? What version driver?
    – heynnema
    Commented May 7, 2022 at 2:40

2 Answers 2

16

I was having this issue. It looks like it's an issue with the desktop launcher file not launching steam correctly due to the system not using the correct GPU on NVIDIA prime systems. I found that there is a defunct steam running on my system already by launching it with the desktop launcher file.

Find the process: ps aux | grep steam

$USER  115599  0.0  0.0  10232  3800 ?        S    14:53   0:00 bash $HOME/.steam/debian-installation/steam.sh -nominidumps -nobreakpad
$USER  115746  0.1  0.0      0     0 ?        Zl   14:53   0:00 [steam] <defunct>
$USER  116535  0.0  0.0   9076  2204 pts/1    S+   14:56   0:00 grep --color=auto steam

Kill the process: kill -9 115746

Run steam again via the command line and it should launch this time around : steam

After that, modify your steam desktop launcher file at /usr/share/applications/steam.desktop change line 38 from PrefersNonDefaultGPU=true to PrefersNonDefaultGPU=false

This requires root privileges, if you don't have root privileges you should be able to use steam via the command line.

Reboot and the steam desktop launcher should work.

1
  • The "Preferred" GPU depends upon what your power settings are: Performance setting makes the more powerful GPU the default, other settings may not.
    – ubfan1
    Commented Oct 25, 2022 at 3:40
2

I also had this problem and changing the default NVIDIA 510 driver to 470 solved the problem.

1
  • Your answer is the correct answer, driver 510 creates also the following issue: askubuntu.com/questions/1414618/… Installing driver 470 fixed bot that issue and the issue with Steam.
    – adi
    Commented Jun 28, 2022 at 6:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .