9

Since I updated to Ubuntu 22.04, Bluetooth has been broken, and I cannot seem to connect my Bose QuietComfort 2 to my laptop.

My headphones are most of the time plainly refusing to connect, and the rare times I manage to connect them, they just disconnect or play garbled sounds.

I tried:

  • messing with the /etc/bluetooth/main.conf file and putting Bluetooth to bredr;
  • pairing through the bluetoothctl command;
  • unpairing and pairing them again;
  • using Blueman.

My laptop is a Lenovo IdeaPad 5 pro.

Result of the lspci -knn | grep Net -A3; lsusb:

03:00.0 Network controller [0280]: MEDIATEK Corp. MT7921 802.11ax PCI Express Wireless Network Adapter [14c3:7961]
DeviceName: Realtek RTL8111E Ethernet LOM
Subsystem: Lenovo Device [17aa:e0bc]
Kernel driver in use: mt7921e

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 13d3:56fb IMC Networks Integrated Camera
Bus 003 Device 002: ID 0489:e0cd Foxconn / Hon Hai Wireless_Device
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
0

4 Answers 4

7

I was having trouble with Bose Soundlink2, the following worked for me. I was using Ubuntu 20.? and then migrated to 22.04. The same thing fixed the newer OS version. Also I had issues with volume but in 22.04 it seems to have been fixed for me.

Install:

sudo apt-get install blueman
sudo /etc/init.d/bluetooth start

Now, install bluez-tools : https://zoomadmin.com/HowToInstall/UbuntuPackage/bluez-tools

sudo apt-get update -y
sudo apt-get install -y bluez-tools

bt-device -r <mac address bluetooth speaker>
0
5

I was having problems pairing my Beats Fit Pro headphones to my brand new Dell XPS 13 Pro laptop running Ubuntu 22.04.1. I tried a lot of different solutions from forums but nothing worked. I ended up fixing my connection issues by manually editing the /etc/bluetooth/main.conf file in a terminal window. I'm not sure if this just coincidentally fixed my pairing issues or if this makes sense to someone more familiar than I am with Linux. All I know is that it allowed me to connect my headphones to my laptop.

Steps

  1. sudo vim /etc/bluetooth/main.conf
  2. Uncomment and update line 65 to FastConnectable = true
  3. Try repairing (successfully)
  4. [Optional] Run sudo vim /etc/bluetooth/main.conf and update line 65 to FastConnectable = false if you don't want FastConnect enabled
3
  • This worked for me. Just set to true then turn bluetooth off and on again. Oct 10, 2022 at 11:30
  • Doesn't work for Ubuntu 22.04 with Sony
    – Coder
    Jan 23, 2023 at 22:15
  • Worked for me on 23.04 only after reboot Sep 3, 2023 at 6:45
0

I have also struggled to play any sound on my Sony WF1000XM3 enter image description here

It appeared to be connected, but I cannot hear the notification from my headphone.

Sound settings output devices and pavulcontrol don't show my headphone either. I searched for some solution and tried reconfigure pulse for weeks but none of that work.

And here is how I fixed it. First, find the device MAC and unregister it.

bluetoothctl
#devices
Device 14:3F:A6:3B:08:2E LE_WF-1000XM3
#remove 14:3F:A6:3B:08:2E
[CHG] Device 14:3F:A6:3B:08:2E ServicesResolved: no
Device has been removed

Start pairing on my headphone (touching 2 buds for a few seconds in my case).

#scan on
# pair 14:3F:A6:3B:08:2E                                       <<<
Attempting to pair with 14:3F:A6:3B:08:2E
[CHG] Device 14:3F:A6:3B:08:2E Connected: yes
[CHG] Device 14:3F:A6:3B:08:2E Modalias: usb:v054Cp0CE0d0312
[CHG] Device 14:3F:A6:3B:08:2E ServicesResolved: yes           <<<
[CHG] Device 14:3F:A6:3B:08:2E Paired: yes                     <<<
Pairing successful                                             
[CHG] Device 14:3F:A6:3B:08:2E ServicesResolved: no            <<<
[CHG] Device 14:3F:A6:3B:08:2E Connected: no                   <<<
# connect 14:3F:A6:3B:08:2E                                    <<<
Attempting to connect to 14:3F:A6:3B:08:2E
[CHG] Device 14:3F:A6:3B:08:2E Connected: yes         
Connection successful
[CHG] Device 14:3F:A6:3B:08:2E ServicesResolved: yes           <<<

If you don't see [CHG] Device <MAC> ServicesResolved: yes after a few seconds. Try connect command again until it is connected.

-1

"bt-device -r "

The finding that mac address requires that you are already paired to the device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .